HELP! Beaglebone Green cannot boot


Can Anyone Help! What should I do?

I tried to control a 4 dc motors 13 sensors setup (4 PWM 8 DO and 13 DI) boot from eMMC without SD card.

After I edited python program for the control but could not save it although I login in with “sudo su”.

Then I tried to reboot with usb to pc but then pc can not detect BBG, NO matter using WIN7 or WIN10.

I can not get connected neither by using Ethernet connector.

Now when I plug in usb, LED D1 always ON, D2~D5 ALL ON for seconds then D2 blink as heartbeat, D3 off, D4 blink, D5 ON for a second then off.

And windows did not detect anything.

My basics are:
</s>debian@beaglebone:~$ sudo /opt/scripts/tools/ git:/opt/scripts/:[e9bcff232834702c1c810710706ee815d77b080b] eeprom:[A335BNLTBBG1BBG217084362] model:[TI_AM335x_BeagleBone_Green] dogtag:[ Debian Image 2018-10-07] bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[l ocation: dd MBR] kernel:[4.14.71-ti-r80] nodejs:[v6.14.4] uboot_overlay_options:[enable_uboot_overlays=1] uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/AM335X-PRU-RPROC-4-14-TI- 00A0.dtbo] uboot_overlay_options:[enable_uboot_cape_universal=1] pkg check: to individually upgrade run: [sudo apt install --only-upgrade <pkg>] pkg:[bb-cape-overlays]:[4.4.20181120.0-0rcnee0~stretch+20181120] pkg:[bb-wl18xx-firmware]:[1.20180517-0rcnee0~stretch+20180517] pkg:[kmod]:[23-2rcnee1~stretch+20171005] pkg:[librobotcontrol]:[1.0.4-git20181123.0-0rcnee0~stretch+20181124] pkg:[firmware-ti-connectivity]:[20170823-1rcnee1~stretch+20180328] groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev us ers systemd-journal i2c bluetooth netdev cloud9ide gpio pwm eqep admin spi tisdk weston-launch xenomai] cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/m mcblk1p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 quiet] dmesg | grep pinctrl-single [ 1.132112] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568 dmesg | grep gpio-of-helper [ 1.144292] gpio-of-helper ocp:cape-universal: ready END <e>


For the record!

I used Ext2Fsd to edit uEnv.txt of SD card and boot BBG from SD card.

And then mount the eMMC block to copy files.

NOW I am good to see what’s going on to the BBG for not booting.