Having trouble with the Grove Indoor Environment Kit

So I recently got a Grove Indoor Environment Kit and I put it together, downloaded the program, ect. But after I booted it up for the first time, about five minuites in it froze up and wouldn’t accept any commands. Any advice?


Can you post a photo of your experimental setup.

Did you get any output before it froze up?

Thanks and regards

Yeah, here it is.

It worked fine for a while, maybe 5 - 10 minutes, but after that it refused any more commands and it completely froze up.
I assembled it according to the instructions, and downloaded all the necessary things, but I feel like I missed something.


Sorry for the delayed reply.

This example works perfectly with Seeeduino/Arduino.

The technical team confirmed that the issue you are facing is due to I2C hardware problem with the Edison board and it cannot be solved by software.

Thanks and Regards

Hey, thanks for you’r advice, I got the board working. But despite that, I’m not getting data through the serial monitor. Everything seems fine and I’m not getting any errors, but it just stays blank. Any suggestions?