GrovePi+ and Grove - I2C Motor Driver (TB6612FNG)


i wanted to run the GrovePi+ (on a RPi 3B+) with the “Grove - I2C Motor Driver (TB6612FNG)” (of course to run a motor with it).
But i think I got the wrong combination?
Would I need the Base Shield?

Or is there a way to run the GrovePi+ with the Motor Driver?
I struggle a little bit cause i dont know where to start.


I tried it anyway, but I got the following Error:
After running the following command:
“sudo python3 -m pip install raspberry-i2c-tb6612fng”
“Could not find a version that satisfies the requirement raspberry-i2c-tb6612fng (from versions: )
No matching distribution found for raspberry-i2c-tb6612fng”

I think its because i try to run it on “Linux dex 4.19.66-v7+” / “Raspbian For Robots” ?

Thanks for your help!

Is it a network problem?

Thank you for the answer!

I think you don´t mean a problem that the Pi can`t connect to the internet in generally? I can connect to the Pi via SSH and also via VPN. I also can ping from the Pi for example to “” without any problem.

Do you mean that there is maybe a problem to connect to the server where I should can download the package?

I have checked some things I found online, for example:

  • pi@dex:~ $ curl --> my IP isnt Blacklistet (but this was not the exact link to the package i think?)
  • I want to try to download it via “wget” but I dont know the exact adress I would have to enter

What could I do next to solve or at first localize the error?

My first thought was, as i wrote, that it is some problem with the OS im running/ that I cant use it with the grovepi+, as on the most sites I find that it is used with the rpi directly.

Thanks for further help!

(I already tried it with the steps from the Website you mentioned:
-> I changed the pip.conf as written and it looks like this:
GNU nano 2.7.4 File: /etc/pip.conf


Than I did the the steps that are following on that site and also ran in the mentioned error.)


i tried a lot i found, but sadly still cant make it running.
Now I get this error:
pi@raspberrypi:~ $ sudo python3 -m pip install raspberry-i2c-tb6612fng
Looking in indexes:,
Collecting raspberry-i2c-tb6612fng
Could not install packages due to an EnvironmentError: 404 Client Error: Not Found for url:

My OS on the Pi3B+: Linux raspberrypi 5.4.51-v7+

Any ideas maybe?