Grove - Wio-E5 (STM32WLE5JC) - Disconnects when transmitting

After spending many hours over the last two days trying to troubleshoot I have run out of options of things to try.

I’m accessing the module with a usb to serial converter which all seems to run fine.

As soon as i try to transmit ether though a test command (AT+TEST=TXLRPKT, “00 AA 11 BB 22 CC”) or (AT+JOIN) the module disconnects and reconnects without displaying anything in the terminal. I was expecting to see ether a join success or join failure message according to the documentation.

Looking at my multi meter as soon as I press join the power drops as soon as i press send which seems odd as the power should increased significantly according to the data sheet.

Turning on the debug log does not seem to provide any meaningful information.

Am i missing something here? Could it be faulty?

It’s quite sure your power supply is not enough for the module ! How do you power it ?

Thanks for the response. At the moment its powered via the USB serial device which is connected to a usb3.0 port on my desktop. From memory i think they are good for up to 500mA but i could be mistaken. I will try power it from another source to see if it makes any difference.

I’ve tried the following power options

  • usb battery - MPM360 adafruit buck converter - Wio-E5 → can’t get it to interact via the terminal
  • 6v battery - MPM3610 adafruit buck converter - Wio E5 → can’t get it to interact via the terminal
    Raspberry Pi Pico 3.3v output - Wio E5 → can’t get it to interact via the terminal

Not sure if i’m doing something wrong here as i would have expected all of those to work, they all seem to output approx 3.25v on my multi meter.

Computer USB port is the worse power supply you can find !

MPM360 according at Adafruit:
entire input voltage range of 6V to 21V
so it can’t be powered properly by a 5V battery, you need to use at minimum 6V and what power is battery you tried ?
May you please confirm you are using the Wio E5 STM32 (chipset itself) and if so how is it wired ?

Thanks for your suggestion about power. I think i’ve narrowed it down to the regulator(5v to 3.3v) on the usb-serial adaptor not coping well. I ended up swapping over to connecting the grove module directly to my Pico board (still powered through the computer usb port) and programming it all in python and to my surprise it has worked fine!

On a side note.

Still not sure why the buck converter didn’t work. The version i am using is this one.

MPM3610 3.3V Buck Converter Breakout - 21V In 3.3V Out at 1.2A : ID 4683 : $5.95 : Adafruit Industries, Unique & fun DIY electronics and kits

Accepts 4.5-21V input with 3.3v output, tried it with 12v DC PSU, 6V (4xaa battery) and 5v DC and on all occasions the microcontrollers behave oddly even though it seems to produce 3.3v on the output!

You should really use a regular lab power supply instead of using cheap electronic board to power the module as it will only get you problems all the time as you have already !

Thanks for the advice, i think i will!