Grove Vision AI Module only shows blank website


I connect the Vision module to the laptop with usb cable. But there is a blank on the popped-out website. I have tried to upload “Grove_AI_default_firmware.uf2” but it does not work.

Also, I tried to use the Seeeduino Lotus to communicate with the module by i2c, however the program seems just freeze at the function “ai.begin()”, In the serial monitor there is only one single line “begin”

1 Like

Have you checked the troubleshooting options here?

Yes, I uploaded grove_ai_without_crc_v01-30 first, then person_detection_pre_17.But still nothing on the website.

Also, I have found out that the program freezes at “_wire_com->endTransmission();”
I use the example code on the Wiki, and my master board is Seeeduino Lotus.

You can give this tutorial a try: TinyML Package Monitor -
If this one does not work either, I think you should proceed for a replacement.

You can recopy the model uf2 file again, the model file and the default firmware are missing.

The current default firmware should be this file. The file name you provided doesn’t look right.

Citric is wrong, well the whole wiki is not made properly.
The wiki wants you to use MODEL_EXT_INDEX_1, whereas you need to use MODEL_EXT_INDEX_2.
Or in other words, to be able to run person_detection_pre_17.uf2 you have to use MODEL_EXT_INDEX_2 (0x11 = 17).

1 Like

When I go to that URL, I see a completely different page.

Oh. Seeedstudio should look into this matter seriously.