Grove Starter Kit for Arduino V3 lcd module won't print

Hi I’m brand new to Arduino and I just Brought a Arduino Uno and the Grove Starter Kit downloaded the library and examples successfully tried a few BUT when I tried the Grove Backlight LCD Module I can’t get it to “Print” any text the background changes color but no text :question:

I’m brand new so Have no idea whats going on anyone got an idea please …
Thanks In advance

RetroBuilder

Hi,

In order to isolate your issue can you please use the following code and send a photograph of the LCD screen output.

[code]#include “rgb_lcd.h”
#include <Wire.h>

rgb_lcd lcd;

void setup()
{
lcd.begin(16, 2);

static uint8_t block[8]= { -1, -1, -1, -1, -1, -1, -1, -1 };
lcd.createChar(0, block);

lcd.setCursor(0, 0);
for (uint8_t i= 0; i < 16; ++i)
lcd.write((uint8_t)0);

lcd.setCursor(0, 1);
for (uint8_t i= 0; i < 16; ++i)
lcd.write((uint8_t)0);
}

void loop() {}

[/code]

Thanks and Regards

Thanks for answering Kavi

I ran the code and pretty much nothing happens just the back ground is lit up
20151209_201417[1].jpg

Ok,Could you please raise a ticket in the following link support.seeedstudio.com/ with the same photo.

Thanks and Regards

Hello,

We can see the base shield switch is not correct. It should be set to 5V when using Grove RGB LCD.

Thanks and Regards

I have exactly the same problem.
I use the grove starter kit for Arduino V3 connected to a UDOO NEO board.
The UDOO NEO require shield powered with 3.3V so I set the grove board power switch to 3.3V.
Backlight is ok but nothing print on the lcd (other modules from the kit are running well).
Should I try to set the switch to 5V without any risk to damage the UDOO board ? If not other idea to solve the problem ?
Many thanks.

We have not tested with UDOO neo board so cant say if it would get damaged.

The grove RGB LCD requires 5V.