Grove Serial Bluetooth can't pair with anything


I have a serious problem with Grove Serial Bluetooth module. I tried to pair module with Mac, Windows and even a Ubuntu machine but without success. I can see the module name in the device discovery tool on my PC but any attempt to pair device fails.


  • I’m using slave example code. I tried to use master code and I was able to see my PC from that module but attempt to connect from the module to the PC fails because it does not accept pin.
  • Sometimes I’m able to “pair” module with my PC but the module is immediately disconnected and red and green LEDs are flashing even if PC reports module as paired.
  • Red and green LEDs are flashing all the time
  • Bluetooth discovery tools reports that the module has no available services. That means it does not offer SPP as it should. This is very strange.

I tried everything possible and I’m almost certain that is something wrong with the module. Is it possible that this module is defective or has some firmware flaw?

Please help…

After configuring module via AT commands over console I was able to pair module with Mac. However the device still does not support SPP so it’s impossible to connect. Same for Windows machine.

Hello ,
It can‘t connected to PC as master, you can firstly upload the slave demo code , and then pair it the Matching password is default “0000” .


Thanks. I know. As I said I’m using slave code I was just trying master code too. Now I’m able to pair module within a few attempts but module does NOT offer serial port. So I can’t connect it even if it’s paired.

Again I tried this on my Mac, Windows and Ubuntu without any success.

If this can help, this is how device reports to my Mac.

You can see that device is paired. But there are no services and device class is 0. Not sure if this is right or not. Mac also does not offer me to create a serial port with this device as I do with other similar hardware.

Is it possible that my problem is related to this?


Module also reports an error when I try to set +LOSSRECONN command. All other commands works just fine.

No as I mentioned in the first post I tried that on Windows and Ubuntu too on different machines with the same results.

It is seems Grove Serial Bluetooth had paired with your MAC refer to the picture you showed . At this time, the green and red LED still flash in turn . You can open the Serial communication tool and establishing the connection .
More details, you can refer to wiki of Bluetooth Shield .


Thanks for the explanation. The problem is that there is no way how to open serial port because after pairing there is no new serial port available. I’m already trying to solve this this with your QC department.

Hi ,
Very sorry that , we have noticed it , that is the battery designed issue .
For you issue , you can try to directly remove the C5 capacitor , and it would be fine …


Oh. Thanks deray!. I will try that and let you know the result.

This really helped! My module is now fully functional! After few months and a lot of hours spent trying to make it working. :frowning: I always thought that this is software problem and never thought about hardware.

One last question. Is it really safe to remove that C5 capacitor permanently? Without any side effects?

Once again Thanks a lot.

removing the C5 is safe. thanks for your feekback…