Grove serial bluetooth - baud rate

Without thinking I set the baud rate to 460800, which I got an “OK” response… but then realized I have nothing that can talk to it at that baud rate… Is there anyway to reset it back to defaults? I tried using the seeeduino Serial.begin(460800) and issuing command to set the baud rate back to 38400 but no response… Did I pretty much brick this one?

Hi there,

This wiki can help you how to use Bluethooth commands.


The bluetooth commands were not the issue, it was that I did not have any device that could actually talk at the baud rate of 460800.

I did resolve it, but in case anyone else does run in to this “problem”, the only way I could find to fix it was to use an ftdi breakout board which does seem to work at the baudrate of 460800 and then issue the command (\r\n+STBD=38400\r\n ) to set the baudrate back to 38400… so now it can talk with the arduino again! Hooray.

Yes, it’s true. Be careful~~ :wink:

I have been using the JY-MCU Bluetooth board, but my application requires the 5V CMOS level of the Grove serial bluetooth device. I can talk to my JY-MCU device just fine, but cannot talk to my new Grove BT board. I can see on the oscilloscope that the baudrate coming from the device is 19200, but the responses are mostly jibberish. I have tried it with and without pin 34 held high to 3.3V based on some information I found on other forums. PuTTY does a paste to host when right-clicking, so I copy things like AT+VERSION
\r\n+STBD=38400\r\n (so if \r\n is code for something else I am supposed to do, this could be my problem)

The data coming in is:
At Power on: baaG A▒b’ ▒bb’ ▒b
Response to \r\n+STBD=38400\r\n: ▒▒k▒
n (so it has a carriage return here before the n?)
Response if I just hit enter: ▒k▒
and if I just keep hitting enter, the response gets longer and longer, like the buffer doesn’t empty?

PuTTY set up is 19200/8/1/none/none in the serial section, implicit LF with CR and CR with LF, local echo force on (but have tried other settings), local line editing is auto, but have tried other settings, I have tried the four different flow controls, I have tried all 5 parity settings. I know I am just missing something dumb. Can anyone help me out?

The cable I am using is an FTDI TTL-232R-5V-WE and it worked on the JY-MCU device. I do not have an Arduino or anything, obviously no real programming skills, so assume I know nothing… :smiley: