Grove NFC v1.1 Problem


the Grove NFC v1.1 board is not working for me with the provided samples for arduino. I tried it in UART mode on Arduino Mega with the code described on the WIKI (PN532_HSU): but I get an error: Didn’t find PN53x board.

As suggested on the WIKI and on the forum, I tried to work in I2C mode, after changing the 3 jumpers: but same error.

Also, I am surprised there is no LED that lights up when power (unlike the grove RFID reader).

Thanks for help.


The jumper connections are specified in the following attachment.
Could you please check if you have properly cut and soldered as shown in the picture.

Thanks and Regards
NFC V1.1.jpg


thanks for answer.

That’s exactly what I did, as explained in your WIKI.

Thanks and Regards,

Thanks for your information.

To which port did you connect your sensor?
Please connect it to I2C port.

Please send us a photograph of Grove NFC connected to the Arduino board.




Thanks and Regards

edited : see solution in the next post.


Could you please change the Grove cable that is used to connect Grove NFC to Base Shield. In the photo that you have sent, the VCC & GND cable are shown exchanged.

Thanks and Warm Regards.


Thanks for answer.

you have good eyes !!! I changed the cable, but the problem is not solved.

Do you think that the NFC component could be broken because of this bad cable ?

Best regards


There is a possibility.

Please ensure the following things:

  1. Connect and power the Grove - NFC. Check if you are getting 3.3V from output of LDO. Use TP5 (i.e 3.3V) & any GND pin.
  2. Also, make sure the UART to I2C PCB jumpers(all three jumpers pad sets) connections are properly set. Use a DMM to check continuity and shorts.

Thanks and Warm Regards


I have the same problem.
I made 3 jumpers on the bottum but i have olways the same massage “Didn’t find PN53x board”.
I check the cable, the draft, the power. I don’t find the mistake.
Can you halp me?