Grove NFC Board 1.1 I2C documentation

I’ve got a load of grove nfc 1.1 boards.

On the wiki seeedstudio.com/wiki/Grove_-_NFC it says to cut the UART->P1 jumper, and solder across P1 and I2C.

But the 1.1 boards have 3 jumpers,

UART -- P1   I2C
RX ---- P2   SCL
TX ---- P3   SDA

and there are no instructions on the wiki about how to change the jumpers for I2C.

I first tried following the instructions on the wiki and just changing the first jumper, like this:

UART    P1  ---- I2C
RX ---- P2       SCL
TX ---- P3       SDA

Not working.

Then I tried moving all the jumpers across, like this:

UART  P1 ----  I2C
RX    P2 ----  SCL
TX    P3 ----  SDA

again it doesn’t seem to show up as an i2c device.

Has anyone actually used the 1.1 board with i2c, and can you tell me what jumper configuration you used. I don’t think my board is broken, because it worked fine on the normal serial connection.

Hello,

Please try the following connection

UART P1 ---- I2C RX P2 ---- SCL TX P3 ---- SDA

and use the code attached.

 #include <Wire.h> 
 #include <PN532_I2C.h> 
 #include <PN532.h> 
 #include <NfcAdapter.h> 
 PN532_I2C pn532_i2c(Wire); 
 NfcAdapter nfc = NfcAdapter(pn532_i2c); 
 void setup(void) { 
  Serial.begin(9600); 
     Serial.println("NDEF Reader"); 
     nfc.begin(); 
 } 

 
 void loop(void) { 
     Serial.println("\nScan a NFC tag\n"); 
    if (nfc.tagPresent()) 
     { 
         NfcTag tag = nfc.read(); 
         tag.print(); 
     } 
     delay(5000); 
 } 

Let us know if you still have any other issue.

Thanks and Regards

I tried what was suggested above and I still get,

please advise

Further, I checked with my multimeter, the jumper pins are connected as recommended for I2C rather than UART

Hey there,



I’ve got the same issue here on at least 3 Grove NFC modules I tried so far. I soldered the connections as mentioned:

UART P1 ---- I2C

RX P2 ---- SCL

TX P3 ---- SDA



But I can’t get it to work… “Didn’t find PN53x board”.



Is there anthing else I can try?



Regards