Grove MicroBit Gesture Error


I’ve encountered problem with Grove Inventor Kit, especially with library for MicroBit. Seems something is not compiling properly, becouse after placing block with Gesture information appears:

Program Error: sim error: failed cast on undefined

It is shown both in web and desktop app.

Hi there,

I tested it and it has the same issue, the software owner takes leave this week. He will focus on the issue next week. thanks.

Thank you!

We are preparing course in polish and gesture recognition was vital feature of our lessons.

i found this error, too. i also tried to import the code to the microbit but it showed error 022. is there anything you can recommend me to solve it? :cry:

Hi there~

We are working on the gesture sensor issue and keep posted here when it is solved. thanks.


is any progress in fixing this bug?

Hello. Same problem, my micro:bit project using grove gesture sensor does not work…

Hi there~

Sorry for the late response, the software team is looking @ the issue, I will post the result when it is done. thanks for understanding.

Hi there~

Finally, the library works. Please test and let us know if any issue. Thanks.


thank you for your work. I tested every gesture and all are working fine.