Grove - I2C Motor Driver & Beagleboard-xM

Hi All,

I have just bought a Grove (Seeed) I2C motor controller module with plans to control 2 DC motor using a BeagleBoard-xM (BB) via the I2C link. The BB uses 1.8v on the I2C SDA/SCL links which I pass through a level shifter to bring it up to 5v, this seems to work fine and I have several other I2C device connected to the bus (RTC, ADC & Gyro) which all communicate correctly.

Now with the motor controller added to the bus I don’t seem to be able to communicate with it, what’s more it seems to stop me communicating with the other devices. I have also tried setting it up with only itself on the bus and it still does not work.

Can anyone suggest what might be going on?

Thanks Ernie

Hi Erine,
I do not use Beagleboard before , so I can not realize your problem clearly.Please make sure that : power I2C Motor board use 5V , and used the right I2C Motor address(default 0x28) , remeber the address if you had changed . Others , that I2C address conflict with other I2C device ?


If you connect the motor driver to the i2c bus, the other devices work normaly?

My motor driver also does not work out of the box. It blockade the i2c bus because the ports both are in input on reset.
The reason is: no firmware.
I upload it and it works :wink:

Check if the other devices works or not…

Hi all,

I have exactly the same issue as Prevoste, but using a RaspBerry Pi board.
Seems the firmware is not ok as all LED are on and as soon as I plug it on the Raspberry Pi, I am not to detect any I2C devices.
I have 4 of them working at 5V with the level translator.

I will re-program the firmware, but have no AVR ISP programmer, have to buy one.

I hope it will solve the issue.

Best regards,


So maybe it’s a bug :sunglasses:

But never mind , we’ll check it . :bulb:

Was this ever checked into? I just bought the i2c motor driver and same result with my raspberry pi.