Grove Hat installation FAILED, FAILED, FAILED

Hello All ,

I am new to this world and was trying to get a Grove Hat for my Pi.
I followed the instructions and tried updating with the shell script given as in installation instructions from

[Seeed-Studio/ Python library for Seeedstudio Grove devices (](

running the below command

curl -sL | sudo bash -s -

But I am always getting an error for

Package 'python-pip' has no installation candidate.
E: Package 'python-rpi.gpio' has no installation candidate

and exits with

` installation FAILED, FAILED, FAILED`

I have python3 and pip3 installed already. I tried installing python2 and pip2 as well.
I tried to install the dependencies myself and got few errors like below

 python3-mraa : Depends: libjson-c3 (>= 0.10) but it is not installable
                Depends: libmraa1 but it is not going to be installed
                Depends: libpython3.5 (>= 3.5.0~b1) but it is not installable

Tried various methods of resolution found on internet but didn’t solve my problem yet and I am still waiting to use my hat.

Please find my Raspberry Pi setup below

  • Device - RPi 4 Model B 4GB
  • OS - Raspberry Lite OS 32 Bit

If you have faced similar issues please let me know any pointers to resolve the same.
Many Thanks

Hello, can you tell me if your computer is Windows or macOS? Are you prompted to update when using the pip command?

Hi Citric ,

I am doing an SSH to the pi from a Windows 10 machine.
I tried today with a new OS flash - still the same. I didn’t try anything else this time. Plain RPi 32 bit Lite OS - then on SSH i directly tried the curl command provided by seed, still getting the same error.

If the online installation method fails, you can try the step-by-step installation. The installation method is shown in the figure below:

I just tried the installation using the Raspberry Pi and it should be no problem.

Alright Citric - let me try that. One more thing which is your Pi image is it Bullseye or Buster ? I am running on a Bullseye - the latest

Oh, I am using Raspbian Buster, which is an engineering prototype.

Citric , I doubt it is because I am using latest Bullseye Image, and the existing seed script may need to get modified. I will downgrade to Buster and see. Meanwhile I will share you a reference.

Errors when installing on a Raspberry Pi running Bullseye · Issue #46 · Seeed-Studio/ (

1 Like

Hello All ,

Finally after banging my head, I downgraded my Rpi OS version to buster , and the script is running without any issues.

1 Like