Grove beginner kit not responding

Having an issue similar to this guy I think: Grove Beginner Kit Error Message

Have read a few threads and installed many drivers and cannot seem to get any positive messages when trying to send code to the board.
What I’ve tried:
Both the CP210 and CH341 drivers
Changing my board type to Uno, Arduino 328P, and Seeduino Lotus. All the same error.
Manually installing the drivers via device manager
Everything in the above thread

When googling this problem it seems like for most people it’s just a matter of installing the drivers. Did I screw up the order of things?

Also would like to note that when I received my package the box had already been opened as if it was returned once already. Not your fault but I’m certainly cancelling my amazon prime.

Edit: It would seem when I plug my Arduino into my USB 3.0 ports, ArduinoIDE lists just “COM1”
When I plug into my 2.0 ports, I see “COM1” and “COM4”. Using COM4 allows me to talk to the board without issue. Due to how my case sits on my desk using my 2.0 ports is inconvenient. Why is using the 3.0 ports impossible?