Grove Base Hat for Raspberry Pi - not detecting i2c anymore

Dear forum,

I’ve connected and installed the Grove Base Hat for Raspberry Pi, everything was working until i’ve used i2cdetect to check addresses. Now i2c is detected but i can’t see anymore the bus address 0x04

Any ideas?
Max

Hi @maxleggieri
You should use sudo raspi-config to enable I2C of your Raspi at No 5 interfacing Options.
If there is no I2C grove sensor connected to the Base shield I2C interface, you can’t find the I2C address.
Check if your grove connector is connected. If those all have no problem, the possible reason is grove sensor hardware damage or sensor I2C problem.

Dear @jiachenglu
I2C is already enabled, i’ve tried 3 different analog sensors on the board on the A0 port of the hat, before installing and using i2cdetect the address was visible, now is not… very strange. You can see in the attached image no address is detected anymore.

Max

Hi @maxleggieri ,
If you had a Grove module using I2C, please it attach Grove Base Hat and run i2cdetect.

Dear @matsujirushi unfortunatelly i don’t have an I2C module… maybe my last chance is to re-write the hat firmware. @jiachenglu @matsujirushi i’ve a jlink to do it, which software i can use to burn the firmware provided on the hat web page?

Thanks
Max

Hi @maxleggieri ,
You can download the firmware here.

Dear @matsujirushi

I’ve reinstalled the firmware and everything is working now.
Thank you so much for your support

Max

1 Like

I’m having the same issue right now. How did you go about reinstalling the firmware? Sorry if that’s a basic question, but I’m new to all this.