Grove AI sensor not seeing image

I got the SenseCap K1100 kit with the Wio Terminal and Grove Vision AI Sensor, but it seems like the vision sensor is not working. When uploading the people detection example to the wio terminal the serial monitor stays empty, and when connecting the vision sensor at SenseCAP Vision AI it says ‘result 0’ with no image. Has anyone else experienced this problem?

Please test the Grove AI sensor with the minimal ARduino setup and code given here:

Please remove any other component that you are using.

Thanks for your answer. However this is the same code I tried, switching to an other microcontroller doesn’t work as well.

Just tried adding a delay after the serial begin and apparently it’s immediately failing when done uploading. Any idea what this could be?


If you encounter the error message “Algo begin failed.” when using the demo, you should first check if the model number is wrong.
You can follow this photo or check the message from the link below to solve your question

Have you tried reset after uploading? Usually a reset will fix the problem of the serial port not printing data.

Change the link into the link below