Grove AI module

grove ai module wont take any of the models neither pre-produced ones or new trained ones. It starts to copy across but then disconnects with no file remaining
I have followed the tutorials for the wio and the drag and drop just wont work. Anyone have any suggestions?

Hello, please refer to this Wiki to train your own model and deploy it.

That’s the one I followed, multiple times. I restarted tried different browsers, different computers each time . Mac and Microsoft . When I view the comm port no detections … also the ai module looks like it copies but restarts

Does the serial monitor output any content or information? There should be error messages in the log. This would help us to determine where the error occurred.

Thanks… The serial output from to wio shows the program skipping to “no identification”

However I don’t get any of the begin msgs…

Eg none of this.

Serial.print("Version: ");
Serial.println(ai.version());
Serial.print("ID: ");
Serial.println( ai.id());
Serial.print("Algo: ");
Serial.println( ai.algo());
Serial.print("Model: ");
Serial.println(ai.model());
Serial.print("Confidence: ");
Serial.println(ai.confidence());
state = 1;
}
else
{
Serial.println(“Algo begin failed.”);

I went through Roboflow and google workspace to build the model and uf2 file. All looks fine.i even tried the already made files. Then doesn’t get to the results msgs either… is there a link to the api so I can modify the code to just show image classification?

I understand, you may wish to contact our technical support email(teachsupport@seeed.io) and one of our engineers will look at the process for you to see if there is anything that is not done correctly.

i turns out i am getting a “code 16 imu failed to initialise error” from the board.

Are you using Wio Terminal’s IMU?

no itsweird, i reloaded the factory firmware and restarted. I just get the no detection thing… The vision module also isnt showing up when I go to the Seeed Studio link which should show the camera view… It connects ok but no images / stream can be seen.
I disconnect and reconnect try different browsers but still no images

I’m not sure if you’re using its image capture function with a master control VisionAI. If not, then it is normal for there to be no image output.