GPRS V2.0 Hardware Serial Direct Connect Problem

Hello all,

So, I needed GPRS on my application and I bought a GPRS shield V2.0.

I’m using a FTDI enabled board (sparlfun XBee Explorer), I have the jumper on the correct position, in order to select the hardware serial. I power the board from the 5V output from the XBee exporer board, the leds light up, I press the power button for a couple os seconds, everything seems to be ok, since I called the SIM I inderted on the module and I don’t get the unconnected message from the network. So, I connected the Tx/Rx pins from the shield to the Tx/Rx pins (Di/Do) on the xbee explorer. Nothing happens. I can’t see nothing on the terminal, try to enter At commands, nothing. I tried all available baud rates. The xbee explorer is fully functional with any other serial devices and I also have a different model that I tried and nothing.

I also have i my posession a 1.0 version of the shield, same behavior. I tried powering woth an external ac adapter, same behavior.

Any ideas?

Thanks in advance.

I’m started to think this is some kind of sorcery… No one experienced this and I’m experiencing with two boards… Frustrating.

Are you sure the pins are the right way around? The shield “TX” pin (D1) connects to the TX (DO) pin of your controller, not to RX (DI). Confusingly, the pin labels on the shield schematic are from the perspective of the arduino, not from the perspective of the shield - i.e. the shield expects to receive data transmitted from the controller on the “TX” line and transmit data to the controller on the “RX” line.


Yes, the pins are correctly sorted. Still, no response from the module.