Gprs Shield with Mega 2560 no communication

Greetings, I have been unable to communicate with my newly purchased gprs shield. It is mounted to an Arduino Mega 2560 board. I have connected pins 7,8 to 10,11, and also specify pins 10,11 in my code. I have tried it on two of the same Arduino Megas, and have tried just about every possible baud rate. On power up I get a string of 255’s. I get no response on hyperterminal nor on sscom32, trying to set the baud rate or just a simple ok from AT command. The flashing green led flashes at 1 second intervals (sometimes at 3 second intervals, I assume indicating network connection).

I have seen the same problems in this forum, but no solution seems to work for me. I don’t think I can update the firmware due to the mega 2560 not having an FTDI(?) chip.

Thanks for any help…

Hex output on startup: 32 35 35 0D 0A 32 35 35 0D 0A 32 35 35 0D 0A 32 35 35 0D 0A

I’ve also tried bending pins 0,1 out of the way and connecting the hardware Serial3 - pins 14,15 to pins 0,1 with the same results.

Disregard the last post!

Connecting the hardware port pins 0,1 to Serial3 pins 14,15 works.

I hope this helps someone.

hey,maybe you forget to plug the jumper(which on the GPRS shield) into Serial mode if you want to use softwareSerial.