GPRS Shield will TX but not display on Terminal


I recently purchased the Arduino GPRS Shield. I have connected it to a Arduino Uno and have followed the wiki and was able to send a text message via hardware UART. The problem is I tried following the first sketch (serial software) but I am unsuccessful at obtaining results. For some reason I am able to TX but the arduino does not show results on terminal. I have used hyper terminal, teraterm, and bray’s terminal. What am I doing wrong? Am I wiring incorrectly since I am using a Uno instead of a Duemilanove?

Thanks for purchasing our product.
You can refer to viewtopic.php?f=4&t=2203

can the firmware be updated connecting the shield with a arduino uno? If so how?

Better using UartSB, and soldering a wire to pin 1 of SIM900 then connect it to GND.

I have successfully updated the firmware… the same issue still happens… do i have a faulty unit?

I had the same problem and never successfully updated the firmware. Could I trouble you for semi-detailed instructions for how you did it? For example, what baud rate did you use, and what sequence. I.e., did you short pin 1 to ground first and then start the upgrader, or start the upgrader first and then short pin 1.

I followed the instructions given, but instead of the adapter stared I used a mini USB from sparkfun connected the 5.5 to appropriate spot and I just held down the power button. If you still have problems I’ll get back to you with more detailed instructions.

side note … I got it to work with hypertermjnal

I would love some more detail, thanks. Here are my questions:

  • What baud rate did you use?
  • Did you point the updater at the RAR file or a file inside the expanded folder? If the latter, which folder?
  • Did you use the broken out TX and RX pins on the board (presumably after removing the jumpers), which are on the 3.3V side of the UART level shifter, or did you use UART pins on the SIM900 itself?
  • What did you use to turn the board on, the PWRKEY switch, a jumper from pin 1 to GND, or something else?
  • What sequence did you use? I.e. did you start the firmware update first, then turn the board on, or did you turn the board on first, then start the firmware update?

(I have tried almost every combination of these that I can think of, except that I haven’t tried all of them with every single baud rate. Still out of luck.)