GPRS Shield Will Not Power Up [SOLVED]

Hi Everyone,
New to the forum and to Arduino. I bought the GPRS V2 shield last week and it was working perfectly…until…I tried to update the firmware. After fighting with it for a few hours I got the firmware update to take, but…I may have stopped the process prematurely (because it sure looked like it was done). Now, it will not power up by the power button (or through software).

The green power light is on (by the power button), but when I press the power button, the red status light never comes on and subsequently, it never initializes. It’s like the shield has power, but what initialization routines the SIM900 tries to run don’t even get called.

I am guessing a bricked the damn thing, but before I run out and buy another one, any suggestions? If I could get it to power on, I may be able to re-flash it, but the flash utility can’t see it because it is waiting for it to power up.


Got it! For anyone who may see this in the future, I am not sure what I did exactly, other than keep persisting. Not really sure what I did, but I tried to erase the flash/firmware (using a flash loader v1.8 NOT the 1.0 version) and setting the erase type to “Source Code”, it worked perfectly!

Just to be clear, because so many are not, I did this with an Arduino Uno R3 board to flash a Seeed GPRS Shield v2.


I set the jumpers on the GPRS shield to HWSerial (see docs), ran a jumper/lead wire from Uno TX (D1) to GPRS RX (D0) and from Uno RX (D0) to GPRS TX (D1). Then, I ran a lead wire from the Uno’s 5V power out to the GPRS Vin and Uno GND (any) to GPRS GND (on power block).

Launched the Flash Loader, clicked the Start download (at 115200 baud) and hit the power button. You have to HOLD the power key until the RAM Loading message hits 100%. Too early or too late, may give you errors. Just keep trying. It’s not exact, but once I saw 100%, I released the power key.

Took about 5 mins.

Hope that helps!