GPRS Shield V2.0 Help

Hi, I have a GPRS Shield V2.0 that I have connected to an Arduino Uno. I tried running the test setup code from the wiki (, opened the serial monitor but nothing showed up (red light is on and green light blinks every 3 seconds). So I tried AT command “AT+IPR=19200” to set the baud rate of the SIM900 and recieved an “OK” Message. I then tried sending an SMS using the AT commands which worked fine. So it seems as though I can send AT commands, but when I start the device and open serial monitor I am unable to get the following (which is supposed to be displayed):
+CFUN: 1
Call Ready

Any idea why the above isn’t printed on my serial monitor, and how to fix it? Thanks.

Normally , the serial monitor don’t display those words unless you set a AT command “AT+IPR=19200” to the board, and then the monitor would display those information while you power on or power off the board.

If it still not be displayed, maybe you can update the firmware(, or refer to the “AT Command Manual” , good luck.