GPRS Shield v2.0 Firmware update [HOW TO - Solved]

Missed something on the resource page, for future reference: to update the GPRS Shield you will need as Serial 2 USB board. For more details: …

I have been trying to setup a HTTPS connection with my GPRS shield, however I am running in to some problems.

Normal unencrypted call through AT+HTTPACTION seem to be working, however when I connect to a HTTPS site I get a 603 response code.

In following link shows the manual regarding setting up HTTPS connection: … 1_00_0.pdf

I followed all the steps, however it seems that the AT+HTTPSSL commando is not working. My only response is “ERROR”.

I’m not sure why this is, could it be the firmware version? How do I investigate this? Any help is appreciated :slight_smile:. Also please let me know if further information is needed.


I have found in the release notes of the firmware that there indeed is a firmware version that supports https:


This verions is based on 1137B09SIM900M64_ST initially, however the instructions to update the firmware are rather limited certainly because the SIM900 chip is already welded on the shield. Can somebody help me with instructions about how to update the firmware of th SIM900 on the GPRS v2 shield?

A little confused, it sounds you have solved your problem, havn’t you? But maybe the wiki of GPRS shield v2 need other more detailed information about firmware update? Anyway, thanks for your feedback.