Got a DSO203... and I'm quite disappointed

First of all, hello everyone here.

Yesterday I received my DSO203, and to my surprise I’ve found it almost unusable :frowning:

First thing I did was the calibration. After that I’ve found that the measures are totally incorrect. I connected the probe on CH A and to my power supply on 5V, the reading that the DSO gives me is 7.58V. I have repeated the calibration like 4 times, and still same issue. After some restarts, it seems the reading has come closer to 5V, but still ~1.8V difference. Totally unreliable and I don’t understand why restarts will modify the calibration.

I didn’t perform the probe calibration, as the signal looked very similar to the ones pointed on the manual as correct.

Next thing, I tried to measure a CMOS crystal oscillator at 1MHz; the frequency displays right at certain scales of v/div and completely wrong at others, but the worse part is that as soon as I modify the T/div, the DSO freezes and I have to reboot :astonished:

With an oscillator at 192 KHz the DSO doesn’t freeze, but the signal in the screen is all the time flicking and/or changing position. Haven’t been able to see a square signal on the screen
a part from the one generated by the DSO’s wave output.

I’ve found also that the reading is so slow, that I cannot see changes on voltages even for a very slow oscillator working on Hz. The voltages remains for most of the time at + some V and randomly goes to + some mV. I would have expected the Vpp to change as the oscillator goes from high to low.

At this point, either somebody tells me I’m doing something completely wrong or confirms to me that this hardware has no reliable use.

Thanks a lot and sorry for the sad mood, but I’m very disappointed.

The hardware is useful, the stock software is total crap. Try the community stuff instead.

Hi jpa, thanks a lot for your reply. What “community stuff” is that? Where I can find it?

Well, there’s gabonator’s DS203 quad user interface design:
but it’s still not complete.

and then there’s the GCC compiled community edition itself:

which included all of Marco Sinati’s firmware improvements:

there’s also Wildcat’s improvements over an older version of the community edition (to be merged in the current version):

and chip’s firmware also (but that’s not open source AFAIK)

Many thanks pmos69. I’ll give it a try and see if it makes my days happier.

This list is useful also:

Calibration is not working in my DSO also.

Hi there,

will the community stuff (including sys etc.) also work with the new hardware revision 2.7B?

many Thanks


i can confirm: YES IT WORKS

But is the calibration problem a hardware or a software issue (or both)?