Getting Windows to recognize the USNoobie


I haven’t been able to figure out how the process of installing the USBasp drivers for the USNoobie is supposed to work.

I’m using the instructions on the USNoobie Usage page here: The driver download is a .zip file named, which contains the driver files but no install program. So, I assume I’m supposed to tell Windows to use the drivers in that folder when Windows prompts for a driver.

I’m not clear on what the button sequence is for launching the USNoobie bootloader. The Usage page says “hold down the bootloader-activation button, then press and release the reset button, then release the bootloader-activation button”, but the video on that page says: press and hold reset, press and hold bootloader, release reset, release bootloader.

I’ve tried both of these, but in either case Windows displays a “USB device not recognized error”, without any reference to usbasp, and without giving an option to provide a driver. Device Manager lists it under “Universal Serial Bus controllers” as “Unknown Device”. I tried updating the device driver from there, but when I selected the folder I unzipped earlier, it displays “Windows has determined the driver software for your device is up to date” message. (Actually, it displays that message no matter what folder I select, so I don’t think Windows has a clue what kind of device it is).

I’m using Windows 7 x32.

I’ve installed lots of USB drivers over the years, and the “Unknown Device” thing usually means a hardware problem. I’m not sure if the problem in this case is something that went wrong with the build, or I’m just not triggering the bootloader. The hardware seems OK - I followed the instructions for testing continuity and voltage in the assembly instructions (which are excellent, by the way), and those tests worked.

Can anyone tell me if the driver installation is supposed to work differently?



I just assembled my USNooBie and I’m having the exact same problem. I think it’s a problem with the USnooBie kits being sold by Seeedstudio. I don’t think the microcontrollers have the bootloader installed on them. If you check out the comments for the product, {link}, you’ll see that another person has had this problem too. This defeats the purpose of the USNooBie for me, I bought it because I don’t have an AVR programmer. I’m going to email Frank (the guy who designed it and wrote the assembly instructions, which I agree are excellent) and see if he has any suggestions.

Yeah, there might be something wrong with the way the 328p in the kit was programmed. I don’t think it is blank, though. I tried reading the flash using a USBtiny and avrdude, and it couldn’t recognize the chip, saying it had a device signature of 0x000000.

I tried writing a copy of the bootloader (downloaded from to a blank 328p that I have, and avrdude failed to verify one of the fuse bits. When I tried using that 328p in the USNoobie anyway, it failed in the same way as the original chip from the kit.

Maybe the bootloader wasn’t programmed correctly onto the 328p in the kit? However, I’m an AVRNoobie, so maybe I’m just using the wrong settings with avrdude and all of this proves nothing.

If you get the answer from Frank, please post it.



I had the exact same results as you when I tried programming with a parallel cable I made. The device signature is 0x000000, so programming can’t proceed. I just thought it was something wrong with my cable, I guess there’s more to it. Could the chips themselves be defective? I don’t have another programmer or chip to test thought. Here’s Frank’s reply to my email:

I’ll email him back with our findings so far. I haven’t heard from seeedstudio yet, maybe they’ll replace the chips if they are defective.


Frank replied to my email and found our problem: the chip comes fused for an external oscillator. Without a clock source, it won’t respond to a programmer. I added a 20 MHz oscillator and capacitors I used to use for PICs between pins 9 and 10, and it started talking over parallel! I tried setting the fuses to the values provided in fuses.txt of Frank’s bootloader zip file, but they wouldn’t verify. I’m not sure if that’s something I’m doing wrong or not, but it didn’t seem to matter in the end. I programmed flash with the 4k bootloader, and now it appears as a USBasp!

Hi Guys:

Please read this quick document I wrote … repair.pdf

Frank, thank you.
Hi Guys,really sorry to late reply and bring such trouble to you,
Please refer to the quick fix as the last post from Frank,
if it is too much trouble, we are more than relieved to replace one for you.

Thank you for to all those that helped solve this problem. I kept wondering if I made a mistake in soldering or I placed something in backwards even after doing the voltage and continuity test. I hope I can find an old computer with a parallel port lol, because gods knows all the new ones, including my current one, doesn’t have one.

I am having an issue connecting the USnooBie to Windows too. Thinking it might have been a Win7 64bit issue I retested under Win7 32bit receiving the same error. I then thinking it might be Windows or driver issue I retested with a Mac and also got an error

I can get the boot loader to run and for it to be detected as USBasp and then drivers install but get the follow errors when trying to upload using Arduino22.

= “Pipe has Stalled”

Windows7 32bit and 64bit
=“avrdude: error: usbasp_transmit: usb_control_msg: sending control message failed, win error: A device attached to the system is not functioning.”

any ideas?