Got a freeduino 1.16 kit a few weeks ago built it and still cant get it to load anything
always get

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

when i plug it in i get a green light from pin 13 and all the pins seems to plus on and off 1 second on 1 second off.

So i tried to make a parrallel port SPI programmer but still get nothing.

any clues to check whats wrong with the board.

Hi gooterz,

The atmega chip has Arduino bootloader .
Because our test skecth flashes the LED .

Did you solder the CRS(100nF) as well ? Or you have to manually reset before uploading.



yeah i have the CRS cap and have also been trying to reset before uploading… nothing seems to work.

Ok so i had some more time… one of the check things i found on the net is removing the AtMega and shorting the Send/Recieve…

When i send data to the board i get the Rx lighting up but never the Tx so the virtual serial is recieving the data but i’m not sure if then it is sending the data to the AT or not recieving it?

Either way something is wrong with the USB controller chip? ideas?

Check to see which chip you’ve got – a 168 or a 328 – and make sure you have the correct board and serial port selected in the IDE. I’ve seen this error when I’ve tried to program a 328 with the 168 settings and vice versa.

Its the 168 says on the top :stuck_out_tongue: