FPGA Configuration Error

I have a brand new DSO QUAD HW Version 2.81, with SYS 1.62, APP Plus A1 (1.13).

Everything was fine until I loaded GABOUI_4.hex

Now I get the FPGA Configuration Error on boot. The bootloader works, so I tried copying FPGA_281, SYS_B162, and PA1_V113, but I still get the FPGA Configuration Error.

I tried copying all three files separately (with a power off in between) and I tried copying all three files one after another and then a power-off. I still get the error.

I’m on a Windows 7/64 box if that matters.

Any idea what to try next?


I didn’t realize I also needed to copy the FPGA ADR file too. After copying the ADR file and the FPGA BIN file, it started working.


Good to hear you have got back to a fixed system.

I think the reason why you had the FPGA problem is that the memory layout has changed in v2.81.

See http://www.seeedstudio.com/forum/viewtopic.php?f=26&t=5512 , in particular the Wildcat posts.

Gabonator is one of the current alternative Apps that does make use of the ‘undocumented’ memory of pre 2.81 hardware and is probably overwriting the new FPGA code area. This could probably be avoided by some mods to the link map for Gabonator to avoid this.