Firmware upgrades with v2 - docs and application changed

When I attempted to upgrade by new DSO nano v2 to BenF’s version 3.5 I ran into a couple of snags

DFuse software is version 3, and crashed immediately on starting.

I am using Windows XP with Service Pack 3, which is more recent than the example ST Micro cites in their docs.

anyone got any ideas?*

*I ran Dependency Walker and it just gave the MPR.DLL – WNetRestoreConnectionA warning, with no other problems

Version 3.50 and v3.51 both loaded without incident on V2 for me. I had failed upgrade verifies during v3.50, but a computer reboot solved the problem. I think the USB network got hosed from another device. A reboot of your computer may be in order.

I am using DFU v3.0.1 on XP Pro SVC PK 3.

Dag nabbit

now two computers have both failed to execute DFuse 3.0

One is Win XP with SP3
The other is Win XP Profession x64 Edition, with SP2 (Intel Xeon)

I have rebooted, and the app still fails to start. Two separate downloads.

There is a DFUSE 3.0.1 out and you may want to try this (uinstall 3.0 first).

Note that there is a separate install for Windows 64-bit.


Thanks Ben, that did the trick. I have now installed 3.5, and I am enjoying the new found ease-of-use and feature improvements!

Can we prompt SeedStudio to upgrade their manual to include this current information?