Firmware upgrade woes

After receiving my Nano and reading about BenF’s efforts here, of course I want to upgrade.

I followed all the steps in the manual (upgrading both the APP and LIB files) and note that after transferring, the verify was successful.

But when I cycle the power, I see I still have the old firmware. During the transfer I did get the error:

"Your device was plugged in DFU mode.
So it is impossible to make sure the file is correct for this device.

Continue however?"

and clicked “Yes”.

Any ideas?

I’m using Win2K, if that’s an issue.



I get that same message before uploading an upgrade - I am using XP running in a virtual machine on a MacBook - but have never had problems with the uplink not working. So that doesn’t sound like the problem.

I have since tried on my XP laptop, with the exact same results.


The only reason I can think of that would explain this, is if you upload the old firmware. That is unless you have a Nano from another manufacturer (not SeeedStudio)?

I downloaded your update from the “DSO firmware version 3.3” thread, and my Nano has the “Seeed Studio” logo on the back. Does it matter that I bought it from RobotShop?

I’ll download the firmware again and try it all again.



I downloaded the update again (this time it’s 3.31) and this time it worked! As it seemed to update faster this time, I checked the files, and for the first set (3.30) both the APP and LIB file were 129KB. In the 3.31 update the APP file is 28K and the LIB files is 14K.

I’m not sure what happened, but I’m good now. Thanks for the help. And thanks for work on this!