Firmware Upgrade doesn't work

I just got my V2 yesterday and like it very much. Read about the BenF enhancements, but am having a problem updating the firmware.

I’m running Windows 7 and have installed the DfuSE demo software. When I boot the unit with ‘down’ depressed I see the two messages
“Please Connect to the USB Host” and
“DS0201 Device Firmware Upgrade Ver 2.0”

But when I then plug the USB cable into the PC I hear the USB device beep twice, but then nothing happens. No “Firmware Upgrading… Please Wait” messages appear.

I’ve tried this many times with identical results. What am I overlooking? Or could this be a hardware/driver issue?

The Nano seems to be performing all of its other operations OK. The only problem is this upgrading procedure.


… I just read the ‘Struggling to Run DfuSE’ message and noted that there should be an “STM Device in Dfu Mode” running with the Nano.

But after starting up DfuSE Demo and then booting the Nano with the ‘down’ key, I see no such device in my Device Manager (see below).

Is there some other drivers that also must be loaded?

… I tried removing and reinstalling the DfuSe Demo, ver 3.0. First time I downloaded it from the STM site. This time I downloaded it from Code Google. Seems to be exactly the same software.

And it still doesn’t work for me, but I’m thinking it’s a driver problem because of the way the installation finished. When I installed DfuSe, both times, it finished by opening the driver folder, with a note that the driver must be installed. The installation notes implied that ‘new device found’ event would occur when you plug in the device, and then you point it to this directory.

But I’m not getting this ‘new device’ prompt. I even forced a hardware scan with the Device Manager, and still no luck.

When I’m in Run mode I can see the Nano as my J: drive ‘USB storage’, if the SD chip is installed. Is that normal? I’ve tried running DfuSe with and without the SD drive, but it still won’t prompt for the new device or firmware load.

Any suggestions on how to fix the problem? Has anyone else encountered a similar problem? Should I try ‘uninstalling’ the J: disk driver?


Look for the reference to dfuse 3.0.1 in the post linked below. This is quite possibly what you need as well.

… af4ex here again. I tried the upgrade on a old WinXP I had lying around, and was successful!

However, I had to install the driver twice to get it to work correctly. The first time I loaded the driver (STDFU.inf) I got an error message that the driver was not installed correctly. (And the Nano didn’t recognize it). So I uninstalled it and tried again, using the same procedure, and the second time it worked.

Now I have the BenF-ware v3.61 running on my Nano V2!

Still don’t know why it wouldn’t run on my Win7 machine.

Thanks for listening while I talked to myself and figured all of this out.

Hi Ben, didn’t see your post until after my last message. I noticed that there was a later version, but couldn’t find it. Not sure I need it now that I’ve got it working under WinXp.

Thanks for Benf-V3.61 !


Similar problem under Wimndoes 7 - USB device can’t be recognized, no driver found…
Has anybody seen any driver or solution for DfuSe and DSO201 under Win7 not to look for WinXP machine?

use arrow left depressed at start up,activate dfuse program.follow directions about dfuse demonstrator. choose your file 1. and check box for the app file 2. verify 3. then upgrade once it says upgrade verified.continue in same difuse window do the same with the lib file.
now shutdown and restart dso nano.this is all in the nano v2 manual.…/DSO%20Nan … anual.pd….

Many thanks!
Upgrade is successful, and my PC detects Nano as removable disk. :smiley:
What have I done (this may help the others):

  • start DSO with DOWN depressed
  • strated DfuSe demo
    … everything as before : PC can’t recognize DSO at USB, asks for some driver, DfuSe doesn’t detect DSO, etc …
    (an old dancing with a tambourine)
  • I started C:\Program Files\STMicroelectronics\Software\DfuSe\Driver\dpinst_x86.exe

PC beeps shortly and miracle happens!