Firmware Update Gone Wrong

I have a DSO201 V1.
I have tried updating the firmware, but now when I turn the device on, I get a white flashing screen.
Any ideas?

The FAQ and a couple of the last 10 posts in this forum should give you some ideas!

I installed 4.22 and all is working fine now :wink:

This is a new Issue on an older thread:

Nano Version 3
DFU Version 3.26D

I have tried a few times to load new firmware and now my unit only will boot to the DFU screen. It doesn’t matter if I hold the down arrow or not.

Been trying firmware from here.
But have also tried the factory 4.22.

The update that killed it was attempted from a windows PC. After many attempts the drive stayed active long enough for me to drag one file there. Could never get the second file to load. I cant remember if I did the AP or the LIB first. I may have restarted at that point.

I have since been trying to load from a linux machine. From there the nano is at least visible as a drive. I’ve tried the latest releases from the forum link above.

Is this thing a brick now?

I would appreciate any help.