Firmware installation issues

Just got my Nano V2. Trying to install BenF firmware. I have DFuSe 3.0.1 and seem to be following the correct procedures. I can see that the USB drivers are installed and have rebooted. When I load the .dfu files, I see progress and messages from the installer indicating that it is erasing the flash then uploading it.

But when I cycle power on my Nano, I don’t have the BenF software coming up.

Any thoughts on what I may be missing here are greatly appreciated!



Did You uploaded 2 files? app and lib(in filename You have app and lib)?

Yes. Lib 3.52 and app 3.61. As found in the ZIP.

Strange. Ive reboot DSO nano in firmware upgrade mode, run DFUSe demo. DFUSe demo showed connected DSUnano device , Ive browsed and pickupped App file first. Checked “verify” option and start updating. Then Ive repeat the procedure for Lib file and after succesfull upgrade Ive restarted DSOnano and it worked.

I am using the same sequence. For each file I see the messages Upgrading-erasing, downloading, verify successful.

I turn off the nano, unplug it, and turn it back on. I am still in SEEED DS0201 app 2.22 lib 2.40

I am running XP sp3. I have even tried turning off my security (Kaspersky).

Is there any self checking in the Nano I can access?

Hmm, do I need to have an SD Card present to use the BenF software?

SD card is not required. Maybe your battery is low.

Output the signal generator to the scope input and test the positive level of the signal (same as battery voltage) at 200us/Div. Use the V1-V2 cursor reading to measure the voltage on Seeed Studio v2.22. If you don’t know how, use the left-right arrows to highlight the V1, then use the up-down arrows to move that cursor line. Repeat for V2, then read the difference displayed. That is battery voltage.

Nice exercise - learned a lot.

measured the square wave at 4.2 v pp. Plugged in the USB and measured 4.76 v pp. Does that sound right?

Yes, anything greater than 3.7V is acceptable, your reading indicates a warm fully charged battery. Can you do a screen capture after the DfuSe Demo has loaded both files and before touching the Nano? Include it here as a jpg file (only picture format permitted other than png).

Edit: Here is what is expected. You can reboot the Nano by pressing the “Leave DFU Mode” button on the demo program. The Nano will reboot in the normal mode and the demo program will indicate a DFU error. This reduces one Nano power cycle. To get back to DFU mode without disconnecting the USB cable, just cycle Nano power with Down Arrow pressed. Although this may sound illogical, if the update fails, repeat a few more times. I have had to repeat on some occasions for reasons unknown, but it eventually takes.

Here are my results. I notice a large size discrepancy. I should load the .dfu files, right?


AH! THat’s it. There is something wrong with the .dfu I extracted from the ZIP. I re-extracted, reloaded, and BenF came right up.

lygra - thanks for holding my hand on that one - no idea how I screwed it up.

MUCH appreciated,