Firmware for the Grove - UART Wifi V2 with ESP8285

I tried to update the Grove UART Wifi V2 AT firmware to the latest 2.2 release without success.
I ended up messing up with chip firmware, and now my board is bricked.
I tried to restore the firmware by using the procedure described here: Grove - UART Wifi V2 - Seeed Wiki
However, the device refuses to boot:

load 0x40100000, len 1396, room 16
tail 4
chksum 0xef
load 0x00000000, len 0, room 4
tail 0
chksum 0xef
ho 12 tail 0 room 4
load 0x00000000, len 0, room 12
tail 0
chksum 0xef
csum 0xef
csum err

Is there someone that can confirm me the firmware available on the Seedstudio wiki works correctly even with the ESP8285 in V2 of the Grove-UART board?

Thanks in advance.

Ok, i found the issue which was related to the different SPI MODE of the embedded SPI memory in the ESP8285, which must be set to DOUT.

But, as I suspected, the firmware on the product page is very outdated:


AT version: 22 2015 19:20:14)

SDK version:1.1.0

           compile time:Jun  1 2015 15:46:19

Where can I download the stock firmware (1.6 if I’m not wrong) shipped with the module?

I finally fixed the board by setting up the ESP8266-RTOS-SDK toolchain and by compiling the ESP-AT 2.2.0 release.
If interested in updating the Grove-UART WiFi V2 firmware, you can refer to this post on my blog