Factory reset of SenseCAP M2 (Helium version aka Light hotspot) make it uselesss

When using a SenseCAP M2 Light Hotspot LoRaWAN gateway (Helium hotspot) (M2-US915) the device will never receive the software update even though is connected to the internet. We’ve tested in several Internet connections, via ethernet and wifi, and I’ve read in Discord that there are 3 more people with the same issue. The top led indicator remains in solid white which means the unit is only with the factory firmware but it never loaded the exact same settings as it came out of the box, it has less features. Already created a support ticket but still the issue has not been solved.

Originally it came with:
Powered by LuCI / OpenWrt 21.02.0 r1-20220322 r16279-5cc0535800
Model M2-US915
Build Version r1-20220322
OS Version 0.9.24-27
Firmware Version v1.0.0-alpha.23.3-23
helium_gateway Version 1.0.0-alpha.23
Helium Address *********key (3word animal name)
LoRaWAN Region US915

After factory reset it lost several modules in LuCi console and it shows:
Powered by LuCI / OpenWrt 21.02.0 r1-20220322 r16279-5cc0535800
Model M2-US915
Build Version r1-20220322
OS Version 0.9.24-27
Firmware Version –

1 Like

thanks for posting, i see you posted on the discord too… I cannt help because i have no knowledge, but i will say that the staff is out for weekend break and should be back around 9PM EST… maybe they will be able to help you… what on earth possessed you to do a factory reset… were you coned by a scammer?

I totally regret doing it, but the instructions said do not try to onboard it to Helium console if it has old firmware, so I unboxed it, and connected to internet. After several hours it didn’t update so I thought maybe resetting to factory will trigger a download of new firmware which is the expected behavior I see, but for some reason this version of M2 loses capability of downloading the latest.

Hi @Jessie1_SenseCAP here are some images of the limited menu that is available after factory reset.

Hi guys,

Happened the same to me.

I got the M2 gateway like two weeks ago and couldn’t onboard to helium due a Bluetooth error. Waited 2-3 days for the gateway to auto update itself to the latest firmware but that didn’t happen, it got stuck on 1.0.0-alpha.23
Navigating by the menus I find the option to factory reset my gateway and continue the process, hopping that by doing this the gateway could now update to the latest firmware and continue the onboarding process as normal, but that didn’t happen, now the hotspot does not displays a firmware version.

I reached for help on discord and this is how I got to this forum. Also I opened a ticket with the support team, but so far they only ask about my internet connection and stop replying more than 4 days ago.

I don’t know why it is such an issue to provide us with the firmware and let us flash the equipment by ourselves, many other brands provide it. I does not need to be the latest firmware, but only one that allow the gateway to connect to the server and initiate an OTA update.

I own another M2 Light hotspot that I bought last year and don’t have this issue at all, it came from the chinese warehouse not the US one, don’t know if that makes a difference.

Please help us solve this issue.


The bug has been fixed yesterday and now the device has been updated to latest firmware. The top led indicator is green now. I’ve read that the other 4 people with the issue have confirmed that it updated itself. The Helium LoRaWAN capabilities and the other parts of the menu has been restored.
Special thanks to the engineers, staff and other stakeholders who helped to fix it!


Hostname SenseCAP
Model M2-US915
SN *****
Build Version r1-20230423
OS Version 1.0.9-38
Firmware Version v1.3.0.2-48
helium_gateway Version 1.3.0
Helium Address ****** (animal-name-3words)
LoRaWAN Region US915
Local Time 2024-06-21 12:29:28 (America/CST)
Uptime 3h 32m 37s
Load Average 0.58, 0.52, 0.55

Powered by LuCI / OpenWrt 21.02.0 r1-20230423 r16279-5cc0535800.

Captura de pantalla 2024-06-21 075105
Captura de pantalla 2024-06-21 075114

For the record, this was the button that I used to factory reset my device. I hope you never have to use it, and if you do, I hope the expected behavior succeeds: automatic firmware upgrade.
Captura de pantalla 2024-06-21 075610
Captura de pantalla 2024-06-21 075533

Sorry guys, this is a known issue, we just fixed it 2 days ago and it should work now.

1 Like