Ethernet Shield support

Ethernet test library:Ethernet_090306.rar (88.5 KB)
A:Download the attached ethernet library.

1.Unpack the file;
2.Place the “Ethernet.rar” to your arduino directory (arduino-0013\hardware\libraries);
3.Arduino0012/0013 should delete the original Ethernet Folder ;
4.Unpack the “Ethernet.rar”;

1.Open the “Ethernet_test ‘Folder’”;
2.Open the “Ethernet_test.pde” ;
3.If necessary,should change MAC and IP address at the top op the sketch

static uint8_t mymac[6] =
static uint8_t myip[4] = 

D: Download the sktch to your Arduino/Seeeduino :astonished:


Moderator edit: This library appears to have a incompatibility. We are investigating at the moment, thank you for your patience


I’m having a few problems with your Ethernet shield… If you would look at my post on the Arduino forum:

Any help would be greatly appreciated.



I have tried the above method, but unfortunately Ethernet_test doesn’t compile. The error message provided is;

A Line is also highlighted (Line 16) when the compile throws the above error; the line that reads as follows;

Ethernet es = Ethernet();

I am running the Arduino software version 0015, although I have tried this code in 0012 and the same error results. I have had a stab at fixing the error in code but I’m afraid that without any context (or knowledge of the example) the error doesn’t mean anything to me (I’m used to Java’s more verbose errors) and so far I cannot work out what is wrong. Any help would be muchly appreciated,

I’ve had a good look through this code and, aside from being terrible, I can’t seem to identify the problem. I suspect it may reside in the supporting libraries (maybe some sort incompatibilty?).

I don’t personally own the device you are using so hopefully someone with experience with this device can help you out. May I ask, why did you not use the inbuilt Ethernet library? I believe the above library is quite old (2006?) and may subsiquently have compatibility issues with the latest GCC-AVR

As I understand it there are two different chips (the two main Ethernet boards) the official board uses a w5100 from WizNet while a number of other Ethernet board designs favor Microchip’s ENC28J60 SPI Ethernet controller. I don’t know the specifics but no doubt there’s a good argument for either case. Anyhow, the Arduino will talk to them in different ways hence the default library (the one that the Arduino software ships with) dealing with the official implementation of w5100 and the third party shields being a little harder to get recent code for because of a lack of a centralized source.

Thank you for having a look through the code anyway, I appreciate it muchly :slight_smile:


Not to worry, I’ll have another look if you have not sorted your problems when I’m a little less busy.

Let me know if you find any hints. Hopefully Seeed Studio may have some thoughts

We test this llibrary,and check what’s problem about it can’t work with Arduino-mega.
The problem seems the hardware SPI is not compatible with Arduino-Duemilanove.
So we will write a library for both.

Oh Excellent, Thank you!

Where will you post an update/notification once the library has been completed? Just out of curiosity, when do you think that the library will be available?

Here is a new revision by Jonathan Oxer :slight_smile: Great work! …

Unfortunately the updated library still does not appear to work, at least for me. Connecting the Arduino and Ethernet boards to my router (using utilities available on my router) I found that the connection to the board was valid (10mbs, half duplex) but that ping requests (using the provided example for pings) simply didn’t work (time out). From the Arduino side I had it write to serial whenever it registered a valid packet but it never did. From this I can only assume that something has gone wrong in the setup (although it appears to complete setting up normally, does not hang and continues to call the loop function as normal). Any idea’s as to what could be going wrong?


Also, (sorry for the double post, I forgot to mention) the two chips on the Ethernet board seem to get rather hot, is it possible that something on the board has broken? If this is the case why is the connection still being set up (the router reports the connection to be at 10mbs, half-duplex)?

I’m sorry for my broken English.

hi, i’m bought Wiznet Ethernet shield - w5100, and i want to use this shield with arduino.
But, I can’t find this shield’s mac address.
I want to know this shield’s mac address, to use this shield.
What should I do, how to know this shield’s mac address?
Please let me know.

by shita