esp32S3 XIAO with round touch screen (seeedstudio) does not display anything

I have XIAO_ESP32S3 and seedstudio round display and nothing is being displayed on screen ( I am using TFT_eSPI_Clock sketch, I red document and it says to correctly define PINS for esp32s3 (XIAO) , could someone tell me what should be values for PINS


Hello, could you tell me which screen are you mentioned?

Hello, after reading your feedback and testing this screen by XIAO esp32s3, I found the library we provided is working well, so I recommend you to check by this list:

  1. uninstall your TFT_eSPI library and install the library we provide: GitHub - Maxwelltoo/TFT_eSPI: Arduino and PlatformIO IDE compatible TFT library optimised for the Raspberry Pi Pico (RP2040), STM32, ESP8266 and ESP32 that supports different driver chips
  2. check whether you have follow the tutorial here: Getting Started | Seeed Studio Wiki, and comment & uncomment the right line in the right file, because there are two same name files, one is in the C:\Documents\Arduino\libraries\TFT_eSPI, the other one is in C:\Users<YOUR COMPUTER NAME>\AppData\Local\Arduino15\packages\Seeeduino\hardware\samd\1.8.5\libraries\Seeed_Arduino_LCD, the Previous one need edited
  3. after check above well, you can use the example TFT_eSPI/320*240/TFT_Clock.ino or examples below the same directory


in file TFT_eSPI/User_Setup.h, I have uncommented following lines


// For ESP32 Dev board (only tested with ILI9341 display)
// The hardware SPI can be mapped to any pins

#define TFT_MISO 19
#define TFT_MOSI 23
#define TFT_SCLK 18
#define TFT_CS 15 // Chip select control pin
#define TFT_DC 2 // Data Command control pin
#define TFT_RST 4 // Reset pin (could connect to RST pin)
#define TFT_RST -1 // Set TFT_RST to -1 if display RESET is connected to ESP32 board RST

and I have uncommented in file TFT_eSPI/User_Setup_Select.h
#include <User_Setups/Setup70b_ESP32_S3_ILI9341.h> // Setup file for ESP32 S3 with SPI ILI9341

and flashed to esp32s3 and esp32s3 panics and contines to reboot again and again

please let me know what I am doing wrong


I have also in file TFT_eSPI/User_Setup_Select.h commented out line below
// #include <User_Setup.h> // Default setup is root library folder

and uncommented
#include <User_Setups/Setup70b_ESP32_S3_ILI9341.h> // Setup file for ESP32 S3 with SPI ILI9341

and flashed it to esp32s2_XIAO and ESP32_XIAO panics and continues to reboot again and again


Hello, here is my file in C:\Documents\Arduino\libraries\TFT_eSPI\ , you can download from here : Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Thanks for files, I downloaded them and flashed it to esp32s3 XIAO after compiling , I am still getting no output on round display


Hello, I hope you can flash the bin file to your board by this tutorial first for acquiring more detailed reason:

  1. the bin file: TFT_Clock.ino.bin
  2. the flash tool: Tools | Espressif Systems
  3. the reference tutorial, remember the address is 0x10000: Generating and uploading BIN files for ESP32 • AranaCorp
    please close the arduino or other com/uart serial tools and open this tools flash the bin into your board, after show success, you need to click the reset button on the board
    if you cannot see the screen with clock plane, I wish you can use a device which install the win10 system but not the win11 system, and try again

could you please give me steps for Arduino, I downloaded both file and compiled and uploaded to esp32s3 XIAO and I am not getting any output on seeed studio round display , then I compiled/uploaded HardwareTest.ino from “Seeed_Arduino_Round display” library and I am still not getting any display output. I am using Arduino on windows 10


it worked , I used second seeed studio round display ,and it works, …Please see attached file

it seems one of display out of two displays could be bad, will it be possible to get replacements…?

You can send an email to for better service