ESP32S3 with LiPo works with attached Sense Module not?

Hey folks,

My ESP32 Sense Module only works with a USB-C connection.

  • ESP32S3 without the Sense Module - everything works, including sketches with WiFi + MQTT, LEDs, and other sensors.
  • The same sketch with the Sense Module → it seems not to boot; nothing works.
  • An example sketch from the Wiki → the webserver AND USB work.
  • However, it doesn’t work with a LiPo battery.

I’ve tried several LiPo batteries ranging from 700mAh to 2000mAh, with the same result. Also changed the ESP32S3 and the Sense modul.

Do you have any idea what else I could check?
Thanks for your help!

Hi there, And Welcome
So can you describe more, or post some code that doesn’t work and a Picture perhaps?
You using the While Serial in the Code?
(waits on a serial connection b4 it continues)
how is the lipo connected?
GL :slight_smile: PJ

1 Like

Hey PJ_Glasso,

that was exactly the tip I needed:

the while series was in the code from the example sketch from Seeedstudio.

  // Serial.begin(115200);
  // while (!Serial)
  //   ;

I commented those lines out and now it works fine :slightly_smiling_face:

All the best

1 Like