Error while implementing google assistant in respeaker core version 2


I just got respeaker core version 2. and I try to implement google assistant in that. i followed the instruction on the seedwiki page, every this goes well until I run the google assistant in it. this is the error

Traceback (most recent call last):

File “/usr/local/bin/googlesamples-assistant-respeakerd”, line 11, in


File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call

return self.main(*args, **kwargs)

File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main

rv = self.invoke(ctx)

File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke

return ctx.invoke(self.callback, **ctx.params)

File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke

return callback(*args, **kwargs)

File “/usr/local/lib/python2.7/dist-packages/googleassistant_respeakerd/”, line 402, in main

pub = system_bus.publish(“io.respeaker.respeakerd”, dbus_obj)

File “/usr/local/lib/python2.7/dist-packages/pydbus/”, line 42, in publish

return Publication(self, bus_name, *objects)

File “/usr/local/lib/python2.7/dist-packages/pydbus/”, line 35, in init

self._at_exit(bus.request_name(bus_name, allow_replacement=allow_replacement, replace=replace).exit)

File “/usr/local/lib/python2.7/dist-packages/pydbus/”, line 29, in request_name

return NameOwner(self, name, allow_replacement, replace)

File “/usr/local/lib/python2.7/dist-packages/pydbus/”, line 8, in init

res = bus.dbus.RequestName(name, flags)

File “/usr/local/lib/python2.7/dist-packages/pydbus/”, line 75, in call

0, timeout_to_glib(timeout), None).unpack()

GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Connection “:1.28” is not allowed to own the service “io.respeaker.respeakerd” due to security policies in the configuration file (9)

can anyone help me to solve this?

Hi there,

Do you follow thanks.

best rgds


yes I followed this link everything well but when running google assistant it gave to the above error what is the problem??

Did you ever find a resolution for this? I’m fighting the same error

Hi there ~

The root cause is the google-auth-oauthlib[tool]. it updated and not compatible any more. So we have to define the version as 0.2.

</s>sudo python -m pip install --upgrade google-auth-oauthlib[tool]==0.2 <e>

We updated the wiki and it can work now. thanks.