Error downloading Seeed Studio when opening board manager

Hi all,

Just having some trouble trying to connect Arduino to the Seeeduino Lotus i’m using. I’ve entered the URL (<LINK_TEXT text=“ … index.json”></LINK_TEXT>) into the additional boards manager in preferences, but when i try to open the board manager to download the Seeeduino board i just get hit with:

“Error downloading <LINK_TEXT text=“ … index.json”></LINK_TEXT>”.

Whats even stranger is that this was working perfectly fine a few days back until the Seeeduino board mysteriously uninstalled itself from Arduino.

Any help would be much appreciated.

Thanks Julian

Hi Julian

Please click the File–>Preferences–>Settings–>click the “C:\Users\xxx\AppData\Local\Arduino15\preferences.txt”. it will open a folder. then you can delete all the files with extension .json/tmp/sig, just leave the preferences.txt/packages/staging. then you can try it once again. thanks.

@bill.yu I am getting the same error connecting a seeeduino v4.2 for the first time, tried to delete the files and repeat, got same result


Could you pls tell me if you can open the links of json file in your Internet browser or ping it in the terminal?


I’m having the same issues,

Error downloading

Seeeduino_SAMD_zero by Seeedstudio doesnt show up in my boards manager.

Thanks in advance


Hi.Can you tell me which module or board you want to use? Tell me the specific model so that I can check it for you.

Hi, its the Seeduino wio lite w600.


Okay, I understand, you can try again following the steps I gave you now.
The first step: Open your Arudino IDE, click on File> Preferences, and copy below url to Additional Boards Manager URLs:

Step 2: Please Click on Toos > Board > Board Manager and search the key word seeeduino_samd_zero to add the Wio Lite W600 into your Arduino IDE. (The key word is seeeduino_samd_zero)

I guess you chose the wrong Library Manager to find the option we need.

HI, thanks for your response. I have successfully installed the seeduino_samd_zero Unfortunately after following your instructions I still cannot find the " Seeduino wio lite w600 " board on the list, the board manager only shows seeduino zero

Okay, in the next step you need to download the library of the board to your computer from this link:
W600 Library
Since you have downloaded the zip Library, open your Arduino IDE, click on Sketch> Include Library> Add .ZIP Library.

Choose the zip file you just downloaded,and if the library install correct, you will see Library added to your libraries in the notice window. Which means the library is installed successfully.

I checked the manual, and the board type to be selected for wio lite w600 is indeed Seeeduino Zero, and there is no problem with your operation. Then enjoy your development journey!

I have a similar problem. I am not longer able to load the .json file.
I bought a new PC. On the old one it worked.

The following errors occure:

Skipping contributed index file C:\Users\silva\Documents\ArduinoData\package_seeeduino_boards_index.json, parsing error occured:
com.fasterxml.jackson.databind.JsonMappingException: Unexpected end-of-input within/between Object entries
at [Source: (FileInputStream); line: 3805, column: 1304]
at [Source: (FileInputStream); line: 3804, column: 26] (through reference chain: cc.arduino.contributions.packages.ContributionsIndex[“packages”]->java.util.ArrayList[0]->cc.arduino.contributions.packages.ContributedPackage[“tools”]->java.util.ArrayList[47]->cc.arduino.contributions.packages.ContributedTool[“systems”]->java.util.ArrayList[3])

Can anyone help me?
I deleted already all files in the folder ArduinoData (except references, staging, packages), but didn’t help. The download of new files worked.

Thanks and kind regards

I have perhaps found the problem.
I think there are some brackets missing at the end of the .json code


I made the necessary adjustments to the json code, but the issue persists, and each time I restart the board manager, the previously stored json file is overwritten by the current one.

I did the same.
But it looks line, that every time the board manager is opened, he downloads the actual json file. This is good to be up to date and needs to be like this.

So i think it is necessary that seeeduino has to debug their code.

@silvan2468 True i tried to remove the link from the prefences.txt still doesn’t work. So I think we need to wait for Seeeduino developers to fix the issue.

Thank you,
That worked for me!

Working fine for me now, without any further action on my side.