Epaper only displays weird lines (with picture)

Hey Everyone,

I am trying to set up an Arduino Mega with a Seeed Studio E-paper shield, but no matter what I do, the only thing I can get on the screen are these weird horizontal and vertical stripes:

Here’s a picture of the thing (just remove the space before the org, I can’t use links because this is my first post :slight_smile: )
s22.postimg. org/lfolxxf0x/20150119_193342.jpg

Right now I’m testing with the official example on Github, but I can’t even clear the screen.

First I tried with an additional E-Paper (as seen on the picture), then with another E-paper shield, but that still didn’t solve the problem :S My Arduino Mega works perfectly for any other task, so that shouldn’t be the problem either.

What could be the problem here?

I would be forever grateful for any assistance

Pay attention to the size of e-paper, if the size is 2.0’, you need to modify the code:

#define SCREEN_SIZE 200             // choose screen size here: 144, 200, 270


I’m experiencing the same issue with a 2.0" screen. I have confirmed that the SCREEN_SIZE in the examples I’m using are set to 200. I am still experiencing this issue. Any other suggestions?

I also have the grey lines showing. I have the 2.7 inch screen and I am using the MEGA 2560.

The screen size is set correctly in the code. The screen initially draws correctly, with black and white areas being clearly defined with sharp lines. Then after drawing the image first begins to fade slightly, with thin lines becoming less well defined. Then bands of grey lines begin to fade into the screen, only a pixel wide but usually arranged in thicker bands across the screen.
These grey lines appear to be unrelated to the screen orientation set using EPAPER.setDirection(DIRLEFT); and for me they run across the short dimension of the screen (right to left if using DIRLEFT as I am here).

I am only powering the board via USB and the Arduino IDE is also telling me that dynamic memory is low and that may effect stability. Perhaps USB doesn’t supply enough power to draw images properly? I might try putting an SD card in despite using the Mega and see if that helps.

I have also attached a photo of the grey lines, I can upload a video as well if that helps.


After I hearing about the Raspberry Pi resetting after a bright flash a while ago I had an idea about the e-ink screen and the grey lines. Putting my finger over the flex cable running to the screen seemed to stop the grey lines appearing. I thought it might also be a slightly loose connection in the flex connector on the shield, but exposing the flex cable to light and pressing on the connector didn’t seem to work.

I also thought it might be something on the screen side of the flex cable but pressing on the metal strip next to the cable and exposing the cable to light again didn’t seem to stop the lines appearing. All I really did was scrape off some of the white silicone covering the metal strip accidentally with a finger nail, that shouldn’t be an issue should it? A thin film came off the metal part only.

It appears that covering the orange flex cable while the screen is drawing stops the grey lines appearing. If you expose the cable to light after drawing they still show up, but they are FAR fainter than they were initially. I think the fix here is to put some very opaque tape or paint or something over the flex cable.


Thanks for posting your info Joshua.

It seems the issue I’m seeing is different. Your screen is at least showing some data correctly before the screen gets garbled. On mine, it just got garbled as soon as I first turned it on and has remained that way ever since. I did try covering the flex connector though and I did not see any improvement.

I am using an Arduino Mega ADK and Arduino IDE 1.6.1.
2015-03-16 15.20.05.jpg

Hmm sorry to hear that didnt fix your issue.
Have you tried putting an SD card into the board? It tells me my Mega is pretty full just uploading the examples, they say the Megas shouldnt need an SD but worth a shot.

Anyway hope you get it working!