Enable uart on pfsense (freebsd)?

I just received my odyssey x86 today and installed pfsense on a hard drive. It has been booting fine but I wanted to enable a serial connection to the uart for remote tty and watching it boot up. I have a max3232 that I’ve tested with raspberry pi machines different Linux system and it worked well. I figured I’d give it a go with this pfsense box as well. I can’t figure out how to enable the uart as dmesg doesn’t show it load but I have the settings in /boot/loader.conf to enable it.

boot_multicons="YES" boot_serial="YES" console="comconsole,efi" comconsole_speed="115200"

I see the ttyu0 in the ttys ttyu0 "/usr/libexec/getty al.3wire" vt100 onifconsole secure

I’m using pins 1,6,8,10 the same as my pi. I also tried the 4 pins that have the red dashed line labeled UART in the pinout diagram? Has anyone else been able to get console tty access via a uart tx/rx?

I may try installing Linux next and testing there as I’m not used to BSD as much.

Hi @krizzo ,

This is currently not supported for the ODYSSEY-X86. Sorry if this caused any issue.

Currently not supported as in there isn’t a way to have getty setup with a UART via tx/rx serial ports? Is the hardware the piece that doesn’t support it? Or is this more it’s not supported in BSD? It’s proven to be a good board with only 2 things wrong/missing. UART support and the fan doesn’t work well with BSD.