Dual Band WiFi Analyzer with Wio Terminal

Hi,
my new Project is Dual Band WiFi Analyzer with Wio Terminal.
Dual-Band-WiFi-Analyzer with Wio Terminal
I have installed the latest firmware and all libraries exactly as instructed on the Wio Terminal.
Unfortunately, the screen is blank after uploading the sketch.
I’ve tried it on several Mac / PC with no success.
What am I doing wrong?

Best Regards,

Paul

Hi @Paul-SN,

We have recently updated the RTL8720 firmware and the Wi-Fi-related libraries:

Make sure the following are updated:

seeed-ambd-firmware - v2.1.2
Seeed_Arduino_rpcWiFi - v1.0.4
Seeed_Arduino_rpcUnified - v2.1.3
Seeed_Arduino_mbedtls - v3.0.1
Seeed_Arduino_FS - v2.0.3
Seeed_Arduino_SFUD - v2.0.1

Please try again with the updates.

Best Regards,
Lakshantha

Hi @lakshan

I don’t know it it’s the same issue or a separate issue: I have made all the updates that you listed, and can’t access wifi anymore . Any call to the library becomes blocking, for example, running the wifi scan sketch given as part of the tutorial freezes on the line "WiFi.mode(WIFI_STA).

I have tried installing a new computer to make sure that it’s not a library conflict, and tried erasing and flashing the RTL8720 firmware again, but wifi access still does not work. Unfortunately, I can’t recall the exact library changes that I made since last week, when wifi access from the sketch was fine. I assumed that something had gone wrong with my terminal, so I ordered a new one this weekend.

Could there be an issue with the latest firmware/libraries ?

Best,
Olivier

Hi @OlivierB,

With all the above updates, Wi-Fi works well on my end.

However, can you tell me your output after running this:

#include "rpcWiFi.h"
 
void setup() {
    Serial.begin(115200);
    while(!Serial); // Wait to open Serial Monitor
    Serial.printf("RTL8720 Firmware Version: %s", rpc_system_version());
}
 
void loop() {
}

Also, did you use Arduino Library Manager to install the libraries?

Hi @lakshan

Thank you again for your message! Calling rpc_system_version() crashes my wio terminal, same as all the rpc/wifi library calls :(.

I called rpc_system_version last week after installing the firmware (and before the problems started happening). It used to show “RTL8720 Firmware Version: 2.1.1”

I tried installing the libraries in two ways : on one computer, using Arduino Library Manager, on the other computer, using the zipfiles downloaded from github. In both cases, I checked that their version matches what you described.

Best
Olivier

Hi @OlivierB,

That’s very strange behavior.

However, to debug this issue further, I have attached two compiled .bin files. One will be for Wi-Fi scanning and the other will be to test the firmware version. Could you upload them to Wio Terminal and try? Also, are you familiar with uploading .bin files to Wio Terminal?

If yes, you could upload and open serial monitor with 115200 baud rate.

WiFi Scanning: https://1drv.ms/u/s!AuZmsghKqp9tiKMGLQoUZWumqHhgJA?e=wuqztg

Firmware Version: https://1drv.ms/u/s!AuZmsghKqp9tiKMHaLS99ca76kRo-A?e=fhA0eT

If that also fails, could you use the below repo to erase the existing firmware and flash new firmware as mentioned in the wiki:

As you can see, the repo has been updated yesterday with the new firmware:

After this, please try again.

Let me know your results.

Best Regards,
Lakshantha

Hi @lakshan

Thank you for your responsiveness and for the advice. I don’t know how to upload bin files to the Wio Terminal, however I have just used ambd_flash_tool to flash the latest firmware as suggested, and it seems to have solved my wifi problems. This is great news. I just ran the network scan and BasicHttpClient samples, and now they work fine, instead of blocking on the very first call to the wifi library.

Thanks again for your help

Olivier

Hi @OlivierB,

Glad to know it works. My pleasure. You don’t need the .bin files anymore because the problem was with the firmware.

Enjoy with your Wio Terminal!

Best Regards,
Lakshantha

Im also faced that issue , the thing i did was just
enable the Serial connection from SAMD51 to RTL8720 by uf2 file, then i flashed the firmware and then i upload the ino code for wifi analyzer and booom… It just worked.

Which firmware version?
Which version of the libraries?
It won’t work with the latest firmware and libraries.

Im not sure about the version but i used this (this has inbuilt firmware and flash tool ) ||https://github.com/Seeed-Studio/ambd_flash_tool|

@Paul-SN,

Please use this guide carefully. It has been updated.

I suggest you to delete the existing libraries as well and start over.

Best Regards,
Lakshantha

I’m having the same issue. I just updated the firmware and libraries, following the videos. The WIO terminal freezes when it gets to “WiFi.mode(WIFI_STA)”. The same thing happens if i use the function “rpc_system_version()”.

Firmware version is 2.1.2 and I’m using PlatformIO.

Any ideas on how I can proceed?

I Like to know why none of the wifi is working, or why the firmware isn’t being updated at the factory