DSOQuadV2.6 RESOURCE(Update 2012/04/12)

DSO Quadv2.6Manual released…Include the basic operation and upgrade methed. and firmware include :logo related file, FPGA logic file, App.hex and Sys.hex.
[size=150]NOTE: firmware for HWv2.2 is not compatible with HWv2.6 . DO NOT upgrade HWv2.6 with firmware for HWv2.2[/size]

[size=150]Latest firmware available(2012/04/12):[/size]
APP: 2.53
SYS: 1.52
FPGA: 2.61
logo: logo file , do not need to upgrade as you do not want to.
[size=150]And, a new designer has joined to design the UI. The following firmware available:(2012/02/14) )[/size]
[size=150]please ref the wiki to track the latest firmware: [/size]
garden.seeedstudio.com/index.php … mware_List

Firmwares that needs to be installed into the DSO Quad:

  1. CFG_FPGA.ADR + VxxxFPGA.bin. The two files for fpga logic, you need to install the .ADR file and then the .bin file.
  2. logo_00B.ADR + logo_001.bin. the logo files, need to install the .ADR file and then the .bin file.
  3. APP_Bxxx.hex, the app firmware.
  4. SYS_Bxxx.hex, the sys firmware.
    when you want to update you firmware, for example, you want to update the app firmware to v2.35 to corrrect the calibration error ,you just need to update the app ,to 2.35, as there is no update in the sys firmware.
    you should do:
  5. download the app 2.35 zip from below lines.
    2.upzip the app, you would see app_B235.hex and DSO Quad Calibration .pdf.
  6. connect the Quad to PC via USB , and power Quad with the ">||"pressed.
    4.copy the App_B235 to the virtual disk . the virtual disk will auto reset and this file changes to :APP_B235.RDY.
  7. Update finished. calibrate the Quad as the DSO Quad Calibration .pdf

updated issue:
1.sys1.34 and .app2.32 can be download now, Please upgrade your DSO QuadHWv2.6 ASAP (2011/4/19)
2.Manual 0.91B added(2011/4/22)
3.Manual to calibrate the probes added(2011/4/25)
4.App 2.33 added(2011/4/27)
5.App 2.35 added,the calibration error been corrected.(2011/5/16)
6.FPGA_V2.5 added(2011/5/18)
7.Manual 0.92B added(2011/5/30)
8.Sys1.37 added(2011/06/01)
9.App2.43 added(2011/06/07)
10.Sys1.41 added(2011/06/07)
11 App2.45 added(2011/06/16)
12 App2.45(b) added(2011/06/17)
13 App2.50 and Sys1.50 added(2011/07/11)
14 New UI ,just for testing!!(2011/07/22)
15 app252/sys151/fpga2.6 released…
16.AP3_P100 released, this is not a offical Version
17. APP2.53 and Sys1.52 released(2012/04/12)
SYS_B152.zip (21 KB)
APP_B253.zip (45.6 KB)
AP3_P100.rar (49 KB)
FPGA261.zip (23.3 KB)
SYS_B151.zip (21 KB)
AP1_B252.zip (32.3 KB)
DS203 new firmware testing.rar (52.8 KB)
SYS_B150.zip (20.5 KB)
APP_B250.zip (30.6 KB)
APP_V245(b).rar (35.7 KB)
APP_V245.rar (35.7 KB)
sys141.rar (22.8 KB)
App_V243.rar (35.4 KB)
SYS_B137.rar (18.3 KB)
DSO Quad v2 6 Manual 0.92b.rar (2.51 MB)
FPGA_V2.5.zip (23.6 KB)
App2.35 and Quad calibration.zip (33.4 KB)
APP2.33.zip (24.5 KB)
How to adjust the C to calibrate the probes.zip (74.3 KB)
DSOQuadV2.6Manual0.91B.zip (2.57 MB)
SYS1.34 AND APP2.32.zip (63.1 KB)
Save wave for DSOQuad.rar (4.06 KB)
DS203V2 6_SCH.rar (62.1 KB)
Quad firmware.rar (58.6 KB)

APP(V2.32) sourcecode released:
SYS(V1.34) sourcecode released:
APP(V2.35) sourcecode released:
FPGA(V2.5) sourcecode released:

and , for some reason, the sourcecode git change
github.com/Seeed-Studio/DSOQuad … SourceCode
to :

Is there new firmware? :blush:

Can we know what SYS1.34 and APP2.32 change to the previous version?

A change log would be usefull when upgrading Firmware so we know what to expect :slight_smile:

I can not upgrade on a Mac, if I boot the device in upgrade mode it continually resets itself so that disk is disappearing faster than I can copy to it. Is there another way, DFU-util or dfuse that I can use.

So I found a Windoze box and it is clear now what the problem is, and it should be simple to fix. Are you interested in fixing it or should I go off and do it myself? I hate seeing forked pools, but this is very annoying. We got the dfuse tool working for the previous mode, not I but others did that which gave us the ability to update from many different platforms. I am not excited by going backwards here.

The DSOQuad HWv2.6 need to upgrade the app/sys/FPGA as the way in the manual because of the BIOS that embeded in the STM32 when Quad was produced . So, DFU-util or dfuse can not be used unless you embeded the related BIOS to the STM32.
as on the Mac, it will be grateful for you sharing your experience that we really lacked .I expececd your detailed introduction

Please tell me what you need to know and I will write it up. On Linux or a Mac the upgrade disk disappears completely every time it checks for new files. (about every second or two) This interrupts copies, or truncates them, and umounts the drive about as fast as the OS can mount it. This makes it so that you can’t copy anything reliably. I even tried to write a script to detect the disk had reappears and then did an ordered copy of the files, but that failed as well. Windows seems to tolerate the disk disappearing for a moment, but Linux and Mac os treat it as if the drive was unplugged while active. So the experience on Windows is good, but it is unusable on Mac os or Linux, even from a program trying to interact with it.

Is this what you need or is it something else? I am willing to help, but it is hard to know what someone doesn’t know. If I were going to fix it, I would change the embedded code to wait for a button press before disconnecting to check for new/changed files. That way you could succeed on copying the files on, before the system sees the disk go away as it now does.


We just received our engineering sample today.
As suggested by the developers, we upgraded the APP to 2.33 and the other SYS f/w updates.

However, now the CALIBRATE button does not work.

Please advice.

you may need to pressed this button about 2s…

Was it faster in 2.32? I recalled that we only need to press it briefly before going into that mode.

yes , this is a little change .

When I attach 2.6 in “upgrade” mode on Linux I see that there are no partitions (just the disk) and it don’t mount, when I connect it to mac osx it ignores it and when I connect it on windows I cannot click on my computer any more as it is trying to mount the disk …

any ideas?

I finally managed to solve the problem, 2win machines were not working just like the linux and mac, third win machine worked with it without a problem … weird

Any idea on when the changes for 2.33 are going to be pushed out to the repository on github?

There is a topic already opened on that problem http://www.seeedstudio.com/forum/viewtopic.php?f=22&t=1934
but no solution for the moment.

I’ve added information on the wiki for upgrading firmware:
garden.seeedstudio.com/index.php … g_firmware

Feel free to make improvements. The process is very complicated and I tried to explain it as clearly as I could.


You may want to edit your original post in this thread in 3 ways

First, you may want to change your sentence about which software to use because it is too vague. You could list the latest file version number for V2.2 hardware, and also show the first file version numbers for V2.6 hardware. For example, only use verAA or lower for hardware v2.2 and only use verBB and above for hardware v2.6.

Second, explain front end compensation is different from the 10x probe compensation, and that these are both different from Quad calibration (input range scale calibration).

Third, you may want to post only attachments of the most current versions of all files here, and remove obsolete versions to reduce confusion.

The filename for the probe compensation attachment should probably be renamed to “front-end compensation and 10x probe compensation.zip” (or words to that effect) for better clarity.

This is just a suggestion on my part. Keep up the good work. :smiley:

What I don’t understand is why those informations are not put on the garden.
As stated on the home page of the garden it is a place where to find “A collection of product info pages” and “Includes datasheet, source files, application notes and related application info”

On the product page there is a version tracker (with no information at the moment) no link to any source file or binary file. As we already ask when we download a new version we have no idea of what this version try to correct or add.


I updated to the latest version, and found a few errors in ‘DSOQuadV2.6Manual0.91B.pdf’. I’d like to report here just to make sure.


I’m sorry if this is a false alarm.


to kotobuki:
thanks for your remind. the manual will be updated .