DSO201v2.4 No power

Got my DSO Nano 2.4 was trying it out for about 30 minutes and then it suddenly turned off. I assumed I had just run out of battery and plugged it into my PC to charge. So far I am unable to get it to turn back on. I have tried different USB ports, cables, PCs. I have tried to get it to charge with the port switch up and down but nothing seems to make a difference.

I did see one post regarding the DSO Nano that suggested some of the batteries in those units were reversed. but I took the back off and to make sure there wasn’t a loose connection. The color of wires seem to be correct red to + black to -.

Anyone experience anything like this? Any tricks to get ti to charge/powerup?

With no more information in what you have said, I recommand you to check the power circuit first .
1.Carry out you barrery , and connect the USB
2.Check the K1 pin_1 and pin_2 , they should be about 5v . if not ,check the forward circuit. pin_1 of U10 if it was 5v , and check the R21 or L2 if it not soldered well.
3.If it does 5v, I could not estimate the potential error . you may need to sent it back to us for repairing or replacing.

Just to clarify: should I be un-soldering the battery or just sliding K1 switch down?

“carry out” i means un-soldering the barrery. what i want to konw is whether it is caused by the battery . so , power the nano with no battery .

Alright had some time tonight, so I unconsidered the battery.
Switch Down:
Across K1: 5.3V
K1 to R21: 5.3V
K1 to U10: 4.9V

Switch Up:
Across K1: 1.4mV
K1 to R21: 5.2V
K1 to U10: 1.2V

As your result, it seems that your nano is short somewhere. You may need to replace it . I have sent you a PM, please check.

Dear open-source-community,

I love you :slight_smile:

I also had the problem: no power with USB, and no charging. I’ve seen on my PCB, that the coil L2 looks a bit burned, and with the multimeter I couldn’t measure a low resistance for it (for coils like 0.01 to 1O Ohm), so the coil L2 must be broken. Thanks to the image out of the schematic from HugeMan, I found out that this coil is just for filtering, so the value isn’t critical. I replaced it with 3 coils in parallel (to allow higher current), from an old broken mp3-player, and voila my device powers up again with USB :slight_smile:

Best regards,