DSO201 "file not exist" error, ver 1.5.


Got a DSO201, ver 1.5, with a 2GB Scandisk micro USB card.
When I try to save a waveform the error message “file not exist” comes up.
The card is formatted in fat16.

Does anyone know this issue?
Would updating the firmware solve the problem?
I’ using Linux, can anyone recommend a programme that works well to upload new firmware (in case it helps…)?

I also tried to find the official forum bbs.e-design…/bbs/ (sorry your spam filter wouldn’t let me post the full URL).
But the domain seems to be gone. So hoping for some help here.


Hello ,

Sorry for the late reply. If you are using version 1.5 , you need to copy a FILEXXX.DAT file in your SD card root before save your waveform. More details, you can refer to our wiki.

Sorry that we do not have a software to upgarde firmware work with Linux. If it still can not solve your problem, suggest you upgrade your firmware with a Windows operate system PC.


Maybe Seeed employees should read the wiki :wink: seeedstudio.com/wiki/index.p … e=DSO_Nano

Of course you can upgrade using Linux.

BTW, the spam filter refused to post your link because it was your first post. Now that you have several posts, you can edit your post and add the link if you like.

Ok now, goinmg step by step.
The first problem was that it wouldn’t let me save a waveform. So started from the beginning:

OS: W7 (I can dual-boot)

  • inserted 2GB Skandisk SD into card reader and connected it.
  • window pops up, asks me to format the drive, ok then…
  • formatted exfat 16kb
  • chose slow formatting, not “quick format”. It took a while
  • moved the SD card over into the Nano
  • started the Nano in USB mode and connected it to the PC.
  • instead of opening the file explorer a window pops up telling me that the card needs to be formatted
    …closed loop.
    Now trying to format via USB cable with card inserted in the Nano.

To be continued…


Your first step should be to upgrade to Ben’s last firmware.

Wish I could…

Returned to W7.
Got the Defuse Demo 3.0.0,
Started the Nano in Upgrade mode,
connected to PC via USB,
started DeFuSe,
no “available DFU and compatible HID devices”. Can’t choose, nothing in the drop down menue.
So no connection.
Could transfer the new Firmware to the SD but not sure if this just won’t mess it all up.

Meanwhile I tried from Linux (Kubuntu):
start Nano in USB mode;
file manager can’t mount the device, well ok then…he didn’t like exfat;
go to partition manager,
SD card was shown, formatted in fat16 (which I can choose as a genuine option there);
made a complete fat16 partition out of the SD card.
created a file file001.dat;
unmounted SD drive;
inserted card in Nano and started it up in normal mode
tried to save a waveform: “file not exist”
connected Nano via USB and also used card reader to double check the SD card: wasn’t mounted, fat16 not there anymore.
return to step 1…

“Started the Nano in Upgrade mode”

What exactly does that mean? How did you do it and what does it say on the screen?

If you have the new USB drive-based firmware loader, you should not use ST Dfuse Demo. Please see the “DSO nano new bootloader firmware” thread.

Sorry wasn’t clear: “Upgrade Mode” = start up while holding “-”.
It shows the E-Design screen saying “Firmware Upgrading” but it doesn’t do anything.

As far as I know when I turn it on in this mode the SD card should appear as a removable drive but it doesn’t. If I want that then I need to start up holding “M” for USB mode.

I followed Alf’s message and copied those two .hex files (V201_LIB.HEX, V201_APP.HEX) onto the SD (see download/file.php?id=1102).
Nothing actually happens. No change, no update.

Did I miss a detail?


Only that? No version for instance?

Sorry, yes the complete string is “DSO201 Device Firmware Upgrade Ver. 2.0”.
Does this mean I’d have to upgrade to Version 2.0 first before I can get to Ben’s? This would then mean I can’t use Ben’s bootloader as I understand.

In fact the main thing I’d like to achieve is to be able to save a wafeform in the end.


This is a very important piece of information that could have helped you avoid a lot of grief and various posts. This is the original boot loader (used on all Nano’s sold by Seeed as far as I know). It means you can forget about the HEX files and USB drive for firmware upgrade which some competitors’ products started using recently. You should use either ST Dfuse Demo or dfu-util, as described in the wiki.

When you plug it into your computer, a USB device of vendor ID = 0x0483 and product ID = 0xdf11 should appear (you can see it with lsusb on Linux or Mac, with some utility like usbview on Windows (or dig through the Device Manager). If not, the upgrading tools won’t see it, and you most likely have a hardware problem.

Well, sorry for the confusion about the boot loader.
Will try to post complete infos now…

I connected the DSO in USB Mode (start+press/hold M). USBview can see the device (i.e. the SD card apparently). But no devices are shown in the dropdown menu of the Defuse Demo 3.0.0.
Should the DSO appear as a separate device apart from the SD card?
I’ve taken the SD card out and started the DSO in USB mode again, same picture so I assume that what’s shown is the DSO not just the SD card. (see screenshot attached.
And yet there is still no device on the Defuse menu.

Explorer: It shows the removable drive. If the SD card is inserted is keeps asking to format the drive despite the fact that it’s been formatted in fat16 many times before.
If no card is inserted, it says “Please insert disk to removable device”. After a few minutes the formatting popup comes as well but not as immediately as with a card inserted.

So format the SD card in fat16. Next time it will ask again…

Hardware problem? Defuse doesn’t run under Linux so can’t try it there. The above are all W7 results.


Strange. If you are booting into the bootloader (“DSO201 Device Firmware Upgrade Ver. 2.0”) there should be no SD card. The USB ID should be 0483:df11 and not 0483:5720 which is the SD card function in the normal software.

Try booting into the bootloader, then plug it into the computer. Do you still see “DSO201 Device Firmware Upgrade Ver. 2.0” on the screen and at the same time the computer detects the SD card (more precisely, USB storage)?

Right, I’ve now updated to Benf’S 3.53 (lIB) / 3.64 v1 (App).
Strangely enough this wasn’t possible on a W7 machine because DFuse wouldn’t see the USB device.
Had to go to an XP machine where it worked at first attempt.

The SD was previously formatted to FAT16 with .dat and .bmp files on it.
If I now want to save a waveform, it says “SD error”.

And I now got a few more questions on top of it:

  • how do I save the settings?
  • where can I adjust the main trigger level (as shown bottom left yellow “Tr”)?