DSO Quad - USB Device not recognized


Just got my Quad and wanted to update the firmware. I connect the USB and powered the Quad with the left button depressed as described. The Quad displays what seems to be a correct mode:

“Device Frimware Upgrade v3.10” and the instructions to copy the files. But Win7 says that the USB device is not recognized. Also tried it on a Win XP machine which did show it as a USB drive, but it was not accessible - saying there was an I/O error with the device.

Do I need some special driver to be installed for Windows to recognize it?

If I just power it up without holding down the left key, Win does recognize it and I can access the 1.96MB drive, but it doesn’t look to be the correct drive.


Sometimes it could be with any usb device if there is something wrong with usb cable. I had the same problem with my photocamera, cheap usb cable and new computer. are you sure in you cable? does computer recognize anything else through this cable?

Spot on! Checked with another USB cable and it worked! So the one that came with the Quad was crap.

Thank you!


you’ve got new experience with usb cables, as me year ago :slight_smile:
some of them are really crap, or are working “on the edge”. it can work with some hardware, and cant with another one.

Dan13, if you have desktop computer and have not working your old cable, if you plug it in front case usb jack, can you check the connection to the back usb jacks - which are on MB? is it working?
sorry my runglish.

Yes checked it on the WinXP machine, but as said it still didn’t work well.

Anyway, with another cable it works now :slight_smile:. Thank you for the help.