Apology in advance in case of repeated post.

Here are info on my DSO Quad out of the box. Hardware Ver V2.70, DS203 Mini DSO SYS Ver 1.52. DS203 Mini DSO APP (Plus A1) Ver 1.03.

I downloaded the attached Upgrade files and the two files inside are FPGA_281.ADR and FPGA_281.bin .

At first, I connect my DSO Quad to Macbook, press and hold ( >|| ) button and power on.

I got the follow message :

Device Firmware Upgrade V3.11C. Please Copy Hex or Bin File to The DFU Virtual USB Disk.

At that time, i am sure i saw 2MB of free space on DFU Virtual disk so i copy and paste both the .ADr and .bin unaware that i am not suppose to copy and past two files at the same time.

Problem starts from there. Nothing happen. No changes on my firmware or anything.

So I try to re-connect DSO Quad to PC and try to do the bootloader again (>||) . This time, on Macbook, i can see the DFU Virtual disk is connecting and also disconnecting at the same time.

I just can’t seem to open the Disk anymore. I tried agin upon my windows 8.1 . Even worse, my explorer freeze and need to hard restart my PC itself.

Please guide my thought how can i go about this problem. I know nothing about DSO Quad. Very new to this. Can’t seem to find the factory reset button or anything at all!
FPGA_281.zip (20.2 KB)

There is no such thing as a factory reset button on the DSO QUAD but it is possible to load the various software components and recover it from almost any software corrupt state.

There are basically 4 different types of sw loaded onto the QUAD

1 DFU This is the start up code and also the means to load the other software components. One should never need to change this normally and it is best left completely alone. If it does get corrupted then it is possible to load it back on by opening the device up, attaching it to a PC via a USB serial cable, and using low level flashing utilities as detailed in other threads.

2 SYS This is a bit like the equivalent of a BIOS in a PC. It provides access to the hardware components in the device like the screen, disc storage and data gathering side of the device. Updates are done by using the DFU loading a hex file

3 FPGA This is a binary image of the instructions that get loaded into the logic array in the device to control primarily the data gathering, FIFO queues etc. It should not normally need updating too often unless one is trying to make the hardware work in a different way. It is loaded via the DFU but comes in two parts; a binary file and the address file which controls where to put it.

4 APPS This is normally the most interesting area for updating as it controls what the device actually does. Normal APPS provide various versions of the main Scope application and others can provide different functions like logic analysers or script based measurements. These are loaded via the DFU using Hex files.

The first thing to establish is what state your device is in. Hopefully the DFU is still intact. If not then you will have to check out the DFU recovery mechanism.

What state is the device in if you just power it up normally, no pressing of buttons? Does it show a splash screen? Does it end up in a normal scope application? Can the Mac or PC see the normal USB data disk? Note that this is completely different to the DFU disk you see when the button is held down during start up.

Then what happens if you try to bring it up in DFU disk mode by the button hold during power up. If possible try to use a different Windows like 7 which may have a more predictable response than 8.1


Many thanks for explanation. Might I ask to what kind of low level flash are you referring to. If you don’t mind do guide me on it.

As for what states my device in is , i’d say its perfectly fine. When i on power without pressing any buttons, it just load up just like usual. I tested it, don’t even need to calibrate at all. And yes, when i turn on the device i could see 2MB of storage.

My problem is when i press ( >|| ) and power on , device load up and said to copy hex or bin fine to the DFU Virtual USB Disk. It’s just that on both Windows 8.1 and Mac Yosemite, the Virtual USB is not responding. On Mac, it contact and straight away disconnected and keep going on till i power off or pull the cable off. Worse in Windows 8.1 , it just freeze my windows explorer and i had to press power button of my PC just to get things run again. This is my main concern. What did I do wrong?

The low level flash is a facility built into the processor chip where its internal program memory can be flashed by sending a sequence of bytes over a serial port. It is often used during the manufacture to put the basic software like DFU on, but can also be used to recover things when all else fails. To do this you have to gain access to the serial port in the device which is some terminals on the circuit board. You would then normally use a USB to serial converter to connect from a PC to this. They are available on ebay very cheaply. You also use a software utility from STM to send the data in the right way. There are detailed step by step instructions and pictures in the DFU threads on this forum.

Of course this all sounds complicated but it’s not so bad. Fortunately it is very rare that one needs to resort to this. It is only if the DFU software has got corrupted and that won’t normally happen unless you try to flash something totally wrong.

If your device is functioning normally during a normal start up then it is probably fine overall. I suspect the DFU problem is more at the USB end of the PC or Mac. They can be a bit finicky particularly accessing specialised devices like a DFU programming port. That is why I recommended trying with a different machine and preferably a different older OS. If anything support for this interfacing has got worse with recent OS’s like Windows 8 as the security on these has tightened up.


Problem solved.
I connected with Virtual XP mode on windows 8.1 , works wonder.
I guess its the OS then.

I installed (drag and drop) the two files i attached, .ARD and .BIN.

Everything seem fine. I even see .ARD change to .RDY after dragging .BIN file.

It just that these are update files right? See nothing different on my device. All same as ever.


Good to hear that’s OK now. Windows 8 can be troublesome in this area.

I wouldn’t expect to ‘see’ any change in updating the FPGA stuff or for that matter in updating sys files as these are just the underlying support material.

Where you will see dramatic changes are if you update the Application files. You can replace your standard stock scope App with one of the alternatives; Community, Wildcat or Gabonator. You can also add new Apps for things like logic analyser, Pawn scripting etc. Now that you can update OK, it is safe to play around with these as you can always load the standard APP back on. You will find the alternative scope APPs much better than the stock one; more stable, easier to use and more functionality. I use Wildcat which is an offshoot of the community app.

There are 4 App slots available. Slot 1 is started by default and 2,3,4 get started if you hold 2,3 or 4th button during power up. But big apps like main scopes typically take 2 slots anyway. So this means that slot 1 and 2 are occupied and 3 and 4 are free for other uses.