DSO Quad Frequency response application


I have made a simple frequency response plotter for the DSO Quad:

My application uses a 8000-point sine wave (instead of the 36-point one in the default firmware, which is quite “stepwise”) and plenty of float math :slight_smile: It kind of proves that the platform has a lot of potential into it.

I have included compilation instructions for Linux and Windows, so it should be an easy starting place for anyone who wants to make small applications for the DSO203.


I’ll give it a try when possible.

Thank you for sharing with us.

On the other hand I think it will be more visible to other users if you post in the Tech Support -> DSO Quad section.


Very impressive. Thank you for sharing this.

Works like a charm!

Also builds without any problem on the gcc toolchain!

Works great. I have some questions. I see what appear to be options at the bottom, like save. I can’t seem to figure out how to save. Perhaps I have to hold a button for a specific amount of time. Can someone offer some guidance?

Also I haven’t figured out how to active the default firmware version. I would like to compare the differences in features. Can some one fill me in on how to activate the default firmware version?

Keep up the good work, your firmware is really handy.

The options appear after the first measurement has completed (or you can abort by holding down a button). After that, use the rightmost thumbwheel to select menu item, and push down the selector to activate it.

The default firmware should boot up if you just turn on DSO Quad without holding down anything.

I feel sheepish, I didn’t know you could press that selector button. That makes this much more understandable now. Thanks for posting, that was a great help.

Hello JPA,
manny thanks for your work.
A fantatstic tool.
First i had problems with the phase, general offset of 53 degree and strange response above 50 KHz.
Was fixed by updating to the latest FPGA-File.

Thanks to all developer for making a fine tool from a toy

Thanks for sharing!

This is one of the apps I was looking for.

One stupid question from a newbie… I own the quad for 2 days!..

how the application can be removed?

The only way to remove applications on DSO Quad is to overwrite it with another one. I’m not sure if there are any other apps using the APP4 location, though :slight_smile:

I think there is another one… I will try to find it… I have read son many threads in so few time…

reading your webpage I found you are doing FFT in this soft.

So, could you please offer the FFT only as an application?

Thanks for sharing.

My FFT (actually just DFT) algorithm is currently very naive and uses floating point math, therefore it is very slow. It is ok as long as it is detecting only one frequency at a time, but getting a whole spectrum would be too slow.

But there is no modification necessary: you can use the frequency response application as a very slow spectrum analyzer by connecting only the input. The phase curve will be meaningless but the amplitude should display whatever you feed into channel A.

Hi jpa I am watching your app with interest.
I am a DCDC converter designer and I am very interested to see if this app could be modified slightly to enable closed loop frequency response analysis of a power supply unit.

The idea is to inject a signal into the feedback loop of the power supply and see how the power supply responds at different frequencies therefore envestigating whether the power supply is likely to go unstable and if it is capable of responding to quickly changing load conditions. The output is a bode plot pretty much the same a you have generated except you would need to plot gains above 0dB

I think also as a precaution I would need to buffer the output signal through a high bandwidth amplifier before connecting it into my circuits to prevent overdriving the DSO Quads internal drive

So what do you think? Are you familiar with the technique and would it be easy enough to add some kind of range adjustment on the dB scale to allow for this?

Sounds interesting; I don’t have any experience in designing SMPS, though.

The DSO Quad analog inputs have some protection already built-in, so the separate buffer may not be strictly necessary.

If you are ok with rebuilding from source (should be quite easy, following the instructions in README), you can adjust the dB scale in the source code. It is in main.c, “MAX_DB”. Default value is 10, just increase it (and also MIN_DB if you want).

This is a fantastic extra - I had asked for one via the forum when I first purchased and this is great.
Your instructions worked just fine first time up with no problems :smiley:

thanks again

Sorry to revive this old post, but … JPA, is it possible to add a frequency cursor, to be able to get a more precise measure of frequency, dB and phase?

I’m not a programmer being, more on the electronics side of things :slight_smile:

It already exists in the QuadPawn version:
github.com/PetteriAimonen/QuadP … y-Response

Many thanks JPA, I’ll try it. BR

Hi there JPA. I tried QuadPawn, but couldn’t run it correctly.

First of all, my current configuration:

Hardware ver.: 2.60
System ver.: 1.60
FPGA: 0.00
DFU 3.10
Display drv.: ILI9327

  1. Tried to load Pawn_011.hex after booting with button 1 pressed, but the copy of hex to USB drive (under Win7) freezes detecting elements, and finishes after several seconds saying the dive is no longer connected. :frowning:

  2. Just to check cables, drivers, etc.etc., did the same thing with original firmware files (Sys_v160, Plus_v110 and App_v251) and the three of them loaded with no fuzz, and Quad still working correctly with Gabonator Oscilloscope … everything ok. :unamused:

  3. Tried then to load AlterBios 0.4, and happened the same as with Pawn_011 :angry:

  4. Just in case I was dealing with corrupt hex files, I downloaded all your files in one ZIP, and began to try with Pawn backwards in versions, and found that v0.10 didn’t load, but v0.08 loaded fine. :open_mouth:

  5. So, after starting Pawn_0.08, tried to copy USB Analyser files (amx and fpg) and the first time, windows asked to format the USB drive, and couldn’t copy the files until I did format the virtual drive :open_mouth:

  6. When I could copy amx and fpg, refreshing Pawn didn’t show any application. :confused:

In summary … there must be something in the files from Pawn_011 and AlterBios 0.4 hex files that prevents them to be recognised by DFU v3.10, and from there onwards, more problems.

Any ideas?