DSO Quad Flash replacement

It seems that my DSO203 has bad 2M flash chip. Often I can’t read saved files, they indicate read errors. I tried to format the partition but same result.
I looks on schematic and found there U13 chip M25PE16. This is it. To fix the situation I ordered several new M25PE16 chips and want to replace the bad one.

Please tell me could I simply desolder my old bad chip and replace it to new one. Or I need to program new chip with some data structure or something like this?

Waiting for an answer from Tech Support. Thanks!

(I’m not seeed’s tech support, I’m just an amateur with some experience with the Quad)

It should be fine if you just format the disk after replacing the flash. There is no special structure AFAIK.

However, another reason for the read errors may be potentially buggy filesystem code in the SYS1.51. I think it occurs if you remove any files on a PC, without removing all the files that have been created after that file. I haven’t tested this bug much, but I have gotten some read errors myself that were solved by formatting.