DSO Quad 2.6 NEWB question about gabonator APP

All I’m certain of is I have Hardware 2.6 and gabonator APP_G251.HEX firmware.

Which SYS should I use with the gabonator APP?

Right now, I just followed the instructions in the readme at his github.
(Can’t post URL, forum software accuses me of spamming.)

which only tells you to upload the APP_G251.HEX.

That’s all I did and things seem ok, but I’m curious.
Definitely a lot better than the HORRIBLE, BIZARRE
UI it came with.

Also, is there any way to get the Hardware, APP, SYS, FPGA versions besides turning the thing on?
The titlescreen flashes by almost too fast to read.

Try the latest build, in About tab it will display version of SYS, DFU… Mine shows this:

here is a link to latest hex:

Thanks! Mine says the same thing as yours except for the serial number.

In the cursors tab, the labels X1, X2, Y1, Y2 are difficult to distinguish. Perhaps make them different colors? Or bigger text labels?

I’m just getting used to this scope and I don’t understand a few things.
Is there a way to see the signal generator output onscreen at the same time you measure someplace else? I mean, using only the one cable. Of course, you can connect one channel directly to the sig. gen output and the other where you’re measuring, but it seems kind of silly using the DSO to measure its own output. Then again, it does have 4 channels :slight_smile:.

Gabonator, I have tried installing the code you linked to above. It installed and showed .rdy but would not run. After the startup screen there was a blank screen. The sys file was not displayed on the startup screen either.

I am using sys 151 and have also tried with 150.
This is similar to the file renaming problem with the Wildcat code.

Hmm, interesting. The first thing that comes to my mind is the display driver. Instead of using LCD functions from SYS module, I have implemented my own routines.
The original firmware supports two different LCD drivers: ILI9327 and R61509V_CPT30. Because my device has ILI9327 lcd driver, my code was designed to work only with ILI9327. But this is my guess, there could be some other reason that it doesn’t work.
If you want to ask me how to find out what is your lcd driver, I don’t know :slight_smile:

It may be your display driver because when I am running your code I have a blank screen but when I press the “circle” button I get a beep. So your app may be running without the display.

But why do I not see your app name on the startup screen along with the sys version?

Try downloading new version, I have added R61509V support. And please give me a feedback whether it worked or not.

Now I have display.
Thanks Gabonator.

Wow, a first case of anyone having R61509V TFT as far as I know.

Bielec: when did you purchase your DSO Quad and from where?

If you can run
(it installs as application 4, hold down button 4 when booting) it would be very useful.

Normal output is

LCD type is 02049327
Official flash size: 256 kB
Test complete: extra flash at 0x08064000 works.


I ran your test and got the folllowing result…

LCD type is 00000000
Official flash size: 256kb

Test complete: extra flash at 0x08064000 works.

I bought my scope more than 2 years ago from an ebay seller. I will try and find who.

Does this mean that I have an earlier version?
What is the significance of this?
Is there a disadvantage?
Should I look to upgrade?


I don’t see the uard decode function in this version. Have you removed it when you did the display modification or is there a special button sequence?

Thanks. This means that your LCD is of different type than the most.

Actually I remembered wrong, there is one other case with LCD type 00000000 also:

Nothing too bad, it just means that we who develop software for the Quad have to remember that there is this LCD type to take into account also. Apparently it was used on the very first DS203’s that were sold.

The only thing missing from the R61509V is a fast way to read back LCD data. It’s not very often needed.

bielec: The uart decoder is activated automatically when you select “Baud” (baudrate analyser) in Meas tab. You can specifiy whether you want to analyze whole sample buffer, samples on screen or from cursor selection.

I have no “baud” option in “Meas”
There are 6 options listed, they are…

Is this a bug?

OK found it within the “measure” + “type” = baud

I can’t update using your firmware, a APP_G251.err appear :frowning:
My DFU is 3.10, HWR 2.60 and I try Sys_152, Sys_151, Sys_150, FPGA_261, FPGA_25 but APP_G251.err still appear and nothing changed.
I’m sure my LCD series is same as yours (saw on jpn’s logic analysis load screen), your “FLASH.HEX” to check LCD is also can’t not update on my DSO quad :frowning:.
My DSO is bought on ebay, I changed DSO logo, sometime files in DSO’s USB storage corupted and I must format to delete them.
Your APP is amazing, wish I can update it.

I did it now, Google Chrome added some html code in to my HEX file and made it useless :blush:
So go to raw,github,com/gabonator/DS203/master/Bin/APP_G251,hex and save file is not a good solution as well :astonished: , I must goto github,com/gabonator/DS203/blob/master/Bin/APP_G251,hex and right click on “raw” button>save as… :confused:

Gabonator, would you like an account to koti.kapsi.fi/~jpa/dsoquad/ ? (It has a web browser upload thingy behind a password.)

I have tried to make it so that .HEX files download from there without problems on all browsers.

why don’t you bring it here: http://www.seeedstudio.com/wiki/index.php?title=DSO_Quad:Upgrading_Firmware
I found all kinds of versions at there.

So far that page has only the official firmware.

But the wiki does not allow file upload, it just has links to other places. And many code hosting places like github don’t handle .HEX download properly, it’s very easy to make a mistake and get a corrupted file.